Mic won't connect

I am running Mac OS 10.14.2, a recent update, I think. In the recent past, I have had no problem using an M-Audio 2x2 interface into the Mac then to Audacity. I set up today, and found that I had to select the M-audio in Mac system preferences, which I did. (pictures attached). I shut down, restarted. The M-Audio is working. The Mac shows incoming signal. I have set Audacity the way it has worked in the past (pictures attached). I get nothing in Audacity, although it seems that the M-audio is correctly selected. Probably some obvious mistake on my part. Can anyone see it?
Screen Shot 2019-01-27 at 10.00.28 PM.png
Screen Shot 2019-01-27 at 10.01.30 PM.png
Screen Shot 2019-01-27 at 10.00.11 PM.png

A recent Mac update denies access to the microphone by default, so you have to “give permission” for Audacity to use the mic.
See: https://forum.audacityteam.org/t/no-signal-from-usb-turntable-mojave-solved/50763/6

Thank you, as usual, for prompt, accurate help. Seems like another of many examples of software trying to retrofit security on a system (the Internet) that didn’t anticipate the need at inception.