mic suddenly not recognised in audacity

Today I used Audacity, normal use, multitrack recording, then it started flickering, so I closed all other applications, and didn’t lose the recording, was able to sav it, but that project no longer recognises the mic (Blue Snowball), which I have successfully used for a couple of years. (So I can’t add to it). Also it is not recognised in new projects either, I’ve tried. I uninstalled Audacity and reinstalled, and it still doesn’t recognise the mic. It states integrated speakers (I use headphones) in the Recording window. Can anyone help?

It would help if you answered the questions in the pink panel at the top of the page.

Reinstalling Audacity only resets its preferences if you enable “reset preferences” halfway through the installer then say “Yes” when Audacity asks about the reset.

If you have the latest 2.0.6 from http://audacityteam.org/download/windows there is a menu item Transport > Rescan Audio Devices top of Audacity which may help.

If there is still no Snowball listed in Audacity, you should look in Windows Sound to see if the mic is still listed there. Here is Windows Sound for Vista and later: http://wiki.audacityteam.org/wiki/Mixer_Toolbar_Issues#vistacp .

Have you checked the USB cable and tightness of the connection?