Mic Failure

I am not at all technical but would like some advice please. I have been using Co1U mic ok for some time. Today I made a recording in the usual way. Moments later I tried again but got no joy from the mic. It is plugged in okay and its green light is on but just not recording. An error message came up to the effect that the link to the input device had failed but, having re-booted the lap top the message has now gone! I’m stuck! Any advice would be welcome, please.

The USB connection probably failed. Unplug and replug it a couple of times and try again. Try, if you can, a different USB connection. Many computers have two or more.


Hi Koz, Thanks, I tried this but still no progress! Any thoughts on what else I could try please?? Keith

We may need to wait for the Windows elves on this one. It is a Windows machine right, because you said reboot my laptop and not restarted my Mac.

It’s possible when the connection failed, Windows abandoned it so now it’s gone even though it’s working OK. That’s a trip down the Windows Control Panel, but I couldn’t begin to tell you where or how.


Yes, you’re right its windows - thanks for your help - I will get the elves involved as soon as they wake up. Many thanks. Keith

Windows elf here - but I’m stumped by this.

A thought: do you have or can you borrow another PC to plug your mic into and see if it works on the second PC - if it does then it will rule out a problem with the mic.


Great idea, elf. thanks I will try it asp. Thanks WC Keith

Hi Guys, Thanks for your help on the one. It was a windows issue of some sort on Vista. For some reason Vista had stopped recognising the mic on audacity. Its way out of my depth but a great guy here fixed it for me - a real windows expert. So if anybody has a similar failure I could get the details and post a more comprehensive fix for guidance. Keith

More details would be welcome. If it happens to one user, there’s a good chance it will happen to someone else.