Metadata Editor -- Copy "Title" into "Album"

…or more broadly, is there a way to COPY one field to a clipboard so it can be PASTEd into another field on the same screen? Thanks!

I think I remember this one. Those are graphics not text, so no, you can’t copy/paste.


The trick with the metadata editor is that you have to click twice in a field to actually select the text. When you see your normal text highlight colour, then you can copy the text. Similarly, you have to click twice in an empty field to select it for text entry (you will see the normal editing cursor) at which point you can paste.

– Bill

Had me fooled a while back too.

Makes you wonder why?

Makes you wonder why?

It was the only free graphics/screen manager module available? A number of oddities can be traced back to problems like that. “Oh, that’s an odd characteristic of the open-source yadda-yadda module we used.”


The Metadata window is basically a table, with input controls embedded in each cell. Most of the controls are plain “text input” controls, but there are also a multi-choice control (“Genre”). The first click in a cell selects the cell. The second click opens the control that is in the cell. You don’t need to click twice to enter text into an empty cell (at least, not on Linux) - you can click once to select the cell and then start typing. You do need to click twice to select the contents of a text cell or scroll down the Genre list.

Makes you wonder why”: It’s so that the Genre list can be embedded in a cell.

It’s so that the Genre list can be embedded in a cell.

I wonder how useful that is given nobody knows it’s there. Copy/Paste is much more likely to be used and Copy/Paste has evolved into a Secret Aural Teachings thing.


“All” metadata editors have a Genre list. Did you not notice the “dropdown list arrow” when you selected the Genre cell?
Click on THIS_TEXT. Did it become selected?
Double click on THIS_TEXT. Did it become selected?
Triple click on THIS_TEXT. What happens?

That behaviour is completely unintuitive.

You can select the labels, but you can’t change them. If you use the tab key to go from cell to cell, you end up in a label, 50% of the time.

Single click in a cell and you can type text, but you can’t paste. You need to click again.

It’s that kind of behaviour that makes newbies nervous. And not only newbies…

And “genre” is just another cell. No drop down list on 2.1.1 on OSX Mavericks.

Another one like this is when you import audio, you can select a project file, but you can’t import it. It throws an error. I know, you should “open” a project. I think a more intelligent approach might be possible, tho.

A lot of this is probably because of PortAudio. Maybe the devs could take a look at WDL?

Portaudio is irrelevant to the Metadata Editor.

What is the relevance of WDL?

Does this not work on Mac? Audacity Manual

No it doesn’t work.

  • The “genre” isn’t a dropdown list until you click it TWICE. It’s empty and looks exactly the same as other fields. Nothing to suggest it might be different.

  • Other fields can be typed into after selecting, but not pasted, after one click. To paste, you need another click. This is insane.

  • The “genre” field behaves even more eratically. It eats the first character you type, unless you click a second time. And that’s every time you select another field and return to “genre”.

Had me baffled the first time I tried it. It leaves a very “unfinished” look if you’re evaluating a program.

WDL has more or less the same goal als PortAudio: cross platform development of audio apps. It parts from a different perspective: being very close to the Windows API, it lets you make Linux and OSX versions without getting in the way. Seems like PortAudio is getting in the way sometimes…

Which version of Audacity / Mac Os X are you using?
Has it ever worked on any version of Mac OS X / Audacity?

Linux support? Developing on Linux - Cockos Incorporated Forums

I still see no relevance to this topic. Portaudio has nothing to do with the Metadata Editor.

I agree it is not intuitive however the basic process does work on Mac exactly as per the Manual. In fact even on Mac you can use F2 after moving into a value cell which then lets you paste.

I can reproduce that on El Capitan in 2.1.1 and 2.1.2-alpha, but that “eat” is the same on all platforms and may not be fixable. The first keypress opens the cell for editing.

Accessing the dropdown genre list is very hard on El Capitan. In 2.1.1 you have to click twice, once on the arrows then again (where the arrows were) to open the list.

In 2.1.2-alpha it is even more difficult to access the list because it won’t stay open. It looks like you have to hold the arrow button down, then while holding, use keyboard arrows to select the required item from the list, then while still holding, press ENTER on the keyboard. Using arrow keys on their own after F2 or double-click does not work because the menu does not stop open.

This may be a wxMac bug but I will document it on Bugzilla and the Manual.

You mean wxWidgets, not PortAudio, which is only an audio API.


Which version of Audacity / Mac Os X are you using?
Has it ever worked on any version of Mac OS X / Audacity?

10.9.5 and 2.1.1. As stated before.

Owww… Well, then it works. Sorry.

Ok, if you can’t fix it, you can’t fix it.

Owww. It gets even worse.

Oh, yes. Sorry. I do mean wxWidgets.

I know, Reaper has no Linux support (as far as we can tell), that doesn’t mean it couldn’t be useful to have a look at WDL, since it can exist next to wxWidgets. Or is that a crazy idea?