menu problem under ubuntu 12.10[SOLVED]

Hi All

I just upgraded my system to Ubuntu 12.10 and use the Gnome Legacy interface. All the menues that are usually along the top menu are missing. file, edit, view, tracks … all missing. I checked on laptop and netbook I have and all look the same. From the ubuntu software install tool I think this is version 2.0.1-1 but can’t get to the help menu to check about.

I tried to remove/reinstall and it looks the same.

I attached a screen shot of the window.


Steve S.

Nothing was attached.

It’s an Ubuntu bug affecting applications built with wxwidgets, see Bug #662077 “WxWidgets apps don't have menus” : Bugs : wxwidgets2.8 package : Ubuntu .

One way of fixing it is to open a terminal and type:

sudo apt-get purge appmenu-gtk appmenu-gtk3 appmenu-qt

A workaround is to CTRL + N to open a new Audacity window (which has its usual menus and icons), or Edit > Preferences and click OK.


    sudo apt-get purge appmenu-gtk appmenu-gtk3 appmenu-qt

Worked fine. Thank you Gale!

Steve S.