Using : Ubuntu 20.04.3 LTS on a Lenovo T470
I plugged USB device Marley
I “see” microphone bargraph changing
but no sound in audacity nor the thinkpad
any idea, advise will be greatly appreciated.
Thank you / Kind regards / Phil

Audacity : 2.3.3

$ sudo -E hw-probe -all -upload
Probe for hardware … Ok
Reading logs … Ok
Uploaded to DB, Thank you!

Probe URL:

Hi again,

I then tried Audacity 3.1.3 from audacity-linux-3.1.3-x86_64.AppImage,
that’s better, because it is possible to record, export and then listen via VLC for example
however it it not possibe (or I didn’t found how to) to listen during recording: How it is possible to do this ?

Thank you

What’s that? A USB turntable? If so, what inputs / outputs does it have?

Hi Steve,
Thank you to take time for me

Marley :

Kind regards

Ensure that you plug in the USB turntable to the computer, and power on the turntable before you launch Audacity.

In the Device Toolbar, select the USB turntable as the recording device, and your computer soundcard as the playback device (the computer’s sound card is likely to be the “(hw:0,0)” device.

Generate some sound in Audacity (from the “Generate” menu) and ensure that you can hear it when you press Play.
If you can’t hear it, you probably need to select a different playback device in the Device Toolbar.

When playback is working:
“Transport menu > Transport Options” and enable “Software Playthrough”.

You should now be able to record and hear what is being recorded.
Note that “Software Playthrough” is slightly delayed (typically around 1 second) due to the time it takes for the sound to work its way from the USB input to the analog sound card output.

Hi Steve,
I will check tomorrow and will keep informed.
Thank you for your valuable advises
kind regards

Hi Steve,

Some good news and some not.
I tried to collect and share with you all information.

Good news : what you suggest is working as expected, of course
Not so good news : it works only for a few seconds, then recording stops.I don’t know why. Sometimes one click on “record” and it starts again, sometimes several clicks are needed, but each time after 1,5,10, 15,45, 60 seconds it stops again.
I made a test on a full vinyle so around 20minutes without the “software playtrough option checked” the recording is working as expected, but of course no playback during the recording.

See the screenshots:
hereafter are the messages displayed when audacity is lauched from the command line, there is no message added when audacity records:

I tried to find but only found libportaudio2 library. I don’t know if this information can be useful

$ ./audacity-linux-3.1.3-x86_64.AppImage
findlib: cannot open shared object file: No such file or directory
/home/phermes/Téléchargements/audacity-linux-3.1.3-x86_64.AppImage: Using fallback for library ‘’

(process:38375): Gdk-CRITICAL **: 10:02:56.379: IA__gdk_screen_get_root_window: assertion ‘GDK_IS_SCREEN (screen)’ failed

(process:38375): Gdk-CRITICAL **: 10:02:56.379: gdk_pixmap_new: assertion ‘(drawable != NULL) || (depth != -1)’ failed
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/gtk/bitmap.cpp(827): assert ““IsOk()”” failed in ConvertToImage(): invalid bitmap
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(2172): assert ““IsOk()”” failed in SetMaskColour(): invalid image
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(2223): assert ““IsOk()”” failed in SetMask(): invalid image
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(1853): assert ““IsOk()”” failed in GetWidth(): invalid image
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(1860): assert ““IsOk()”” failed in GetHeight(): invalid image
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(2112): assert ““IsOk()”” failed in GetAlpha(): invalid image
//build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(2232): assert ““IsOk()”” failed in HasMask(): invalid image
/_/build/387c18a58e2fde1ef9c941329038b8fc62a56b98/source_subfolder/src/common/image.cpp(1986): assert ““IsOk()”” failed in GetData(): invalid image

(process:38375): GdkPixbuf-CRITICAL **: 10:02:56.382: gdk_pixbuf_new_from_data: assertion ‘data != NULL’ failed

(process:38375): Gdk-CRITICAL **: 10:02:56.382: IA__gdk_screen_get_root_window: assertion ‘GDK_IS_SCREEN (screen)’ failed

(process:38375): Gdk-CRITICAL **: 10:02:56.382: IA__gdk_drawable_get_display: assertion ‘GDK_IS_DRAWABLE (drawable)’ failed

(process:38375): Gdk-CRITICAL **: 10:02:56.382: IA__gdk_cursor_new_from_pixbuf: assertion ‘GDK_IS_DISPLAY (display)’ failed

(process:38375): GLib-GObject-CRITICAL **: 10:02:56.382: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

One more time, I appreciate your time taken to exchange and help me.
Kind regards

Try using “Pulse” for recording, and use the PulseAudio volume control to connect Audacity to the turntable in the PulseAudio volume control “Recording” tab.

“PulseAudio volume control” may be your default audio mixer, but if not, launch it from the command line with: