Make Waveform keep up with recording

When I start recording the Waveform displays correctly until it gets to the right side of the window and then the Record position bar disappears. I kind of expected it to keep shifting to the left so the current record position always showed. I could make the scale larger, but at some point the waveform is so small it is not useful. Does the same thing with Playback, position bar scrolls right and disappears. Is there a way to do this with Audacity 2.1.1 on Windows ? I do a lot of video editing and those editors work that way, which was why I expected the same from Audacity.

Go to Edit > Preferences > Tracks and make sure that Auto-scroll if head unpinned is checked “on”


This should be checked “on” by default in Audacity but you may have accidentally unset it.

I’m not really sure why we still have this preference - I recall that it stems from many years ago with lower-powered PCs which had difficulties in keeping up with audio and graphics simultaneously - I will discuss this on our QA email list.



I’m running 2.2.2 but the Option was the same. And I am going to update to 2.3.3 as soon as this recording is complete. :smiley: Sorry the reply took so long, but I kind of stepped away from audio recording for a while and just got back.
Thanks again, Jack