Make Stereo: White Space Trap

Audacity 2.1.2

I love the ability to make a stereo track from the track drop down menu. However, I can’t trust this function any more. Trailing white space in the first track leads to unexpected results:

  • Create 2 signals, a few seconds long.
  • Align the tracks end to end.
  • Choose “Make Stereo Track” from the first track’s drop down menu.

The white space in the first track (where the second track starts) is not rendered as silence but does instead repeat the preceding content of the first track.
The workarounds are rather awkward and defeat the purpose of “make stereo”:

  • make Track 1 left and track 2 right → mix and render
  • or generate silence at the end of track 1.


I’m not seeing that (on Linux). It is a bug if it is happening.
What happens when you split the stereo track?

Update: Tested on Windows XP with Audacity 2.1.2 downloaded as ZIP and with a “Portable Settings” folder added.
My steps:

  1. Generate tone (default settings)
  2. Ctrl + D (duplicate track)
  3. Tracks > Align > End to End
  4. First track dropdown menu > Make stereo track.
    The stereo track has 30 seconds of tone in the left channel and 30 seconds of white-space followed by 30 seconds of tone in the right channel (as expected).

Here is what I hear:

It happens under different hosts , with different audio buffer settings and also after a restart.
Note: the audio is correctly exported, the attached file is only a loopback recording.
After splitting, the playing is correct as well.
I’ll try again after a computer reboot.

Ooh, that’s wrong. I don’t get that on Linux or XP.

It happens still, after re-building Audacity and a computer reboot.

Yet another oddity: it plays correctly with looped playback (shift-space).
I don’t know if my Behringer UMC204 has anything to do with this issue, I can’t imagine why this should be the case.

Are you using Audacity 2.1.2 installed from the exe installer?
Please give exact steps to reproduce, then we can see if I or anyone else can reproduce the issue.

No, I use the compiled release version (newest build).

Your steps above were right.

  • new project
  • create tone (or noise)
  • duplicate
  • home key
  • align tracks end to end
  • move to first track, make stereo


OK so this is a playback problem. Yes I get that on Windows 7.

It’s a regression on 2.0.6, so perhaps something that happened with the changes to real-time effect playback. I’ll add it to Bugzilla when I have tried it on other machines/platforms and decided importance. Probably P3.


Thanks Gale
Always nice to have a suspicion confirmed.
Perhaps, the Portaudio update will solve this issue - fingers crossed.

Workaround for now:
Mix and render the track after “Make Stereo Track”.


I’ve added the bug (P3) I’m surprised it’s gone unreported for so long.


I wasn’t even aware there was a function like “make stereo”. I always use your workaround. Like to make things complicated, I guess… :smiley:

Indeed, but users don’t create stereo tracks from scratch usually.
I’ve stumbled upon because I wanted to show something in respect to the noise generation in Audacity (uniform versus Gaussian distribution).

Thanks for the report Gale.