Make failing on Ubuntu 16.04

On master branch, made a minor change to add a try-catch in one file so it’s practically clean. When I run make, I get a failure in what looks like the translation directory:

make[2]: Entering directory '/home/tom/Projects/audacity/audacity/locale'
: --update  --lang=af af.po audacity.pot
rm -f && : -c --statistics --verbose -o af.po
mv: cannot stat '': No such file or directory
Makefile:742: recipe for target '' failed
make[2]: *** [] Error 1

Anyone know what to do? Thanks!

Does it build if it is “actually” clean (unmodified)?
What was the change?

Reset the file, build still fails for same reason.

Change was in src/import/Import.cpp line 501, I wrapped:

auto inFile = plugin->Open(fName);

in a try-catch block:

      std::unique_ptr<ImportFileHandle> inFile;
         inFile = plugin->Open(fName);
      catch (onst std::exception &e)
         wxLogDebug(wxT("Open with %s failed, file may be corrupted"),plugin->GetPluginStringID().c_str());)

Did you try building Audacity before modifying the source code?

No, but I’ve reset it to a clean copy, and it’s still failing. Anyway the error make throws doesn’t seem to have anything to do with the file I modified.

Never mind; I installed “gettext” (which was not installed before) and it works now. I hit some other make errors after that, but was able to resolve them by installing build-essential and gnome-devel. Thanks though!

Glad you got it working.

For the benefit of other readers, on Ubuntu / Debian based systems, “build-essential” is a prerequisite and should be installed first, then Audacity’s other dependencies may be installed with the command:

sudo apt-get build-dep audacity