Make all Tracks Fit

macOS Sierra
Audacity v2.2.2

Audacity is set to record on 3 Channels.

When I open a new project and hit “Record” the 3 Tracks that Audacity creates to map to the 3 Channels I am recording are really tiny.

(I find this strange, because before I added a 3rd channel, when I would hit “Record”, my stereo tracks are “maximized” by default.)

If I go to View > Track Size > Expand Collapsed Tracks (Shift+Cmd+X) and then View > Track Size > Fit to Height (Shift+Cmd+F), then I get this…

Looks good, but what a pain to have to do all of that to get things to look as I feel they should by default.

Is there any way to fix this issue?


Mac Audio

Go to Tracks preferences and try checking “on” the “Auto-fit track height”
See this page in the Manual:


That doesn’t work when I have Audacity’s “Recording Device” pointing to my virtual Loopback device which has 3 channels and I have Audacity’s “Channels” set to 3.

Then I get what I showed in my OP.

From the code, the behaviour that you observe appears to be what is intended, though I tend to agree that it is not the expected behaviour. I would not expect the tracks to be minimised when “Auto-fit track height” is enabled.

So this is how Audacity is built?

Why does this work for stereo recordings, but not when there are 3 channels/tracks?

It’s not that it “doesn’t work”. It works exactly the way the code tells it to work.
This is the relevant bit of code:

if (recordingChannels > 2) {

which is saying, “if more than 2 channels are being recorded, set the tracks to collapsed”.

I presume that the reason for this design decision, is the assumption that if the recording is not mono or stereo but “multi-channel”, that the project is likely to end up with a lot of tracks, so the tracks are set “collapsed” by default to allow more tracks to be visible on screen. I’d also guess that it was designed this way before the option to “Auto-fit track height” existed.

In my view, the more expected behaviour would be for the code to be:

if ((recordingChannels > 2) && !(p->GetTracksFitVerticallyZoomed())) {

which is saying “if more than 2 channels are being recorded, set the tracks to collapsed, unless the user has selected the preference to Auto-fit track height”.


Thanks for the explanation, but I have a coding background.

Just out of curiosity… What language is Audacity written in?

Oh well, this is a minor annoyance, but not the end of the world.

I have trained my brain to quickly do cmd+shift+x and cmd+shift+f and things look like I want.

Mostly C++

Okay, cool.

And, yes, I would have programmed things as you described above. (Maybe in a future version?)

If you want to make the modification yourself, this bit of code is in ControlToolBar.cpp.
The Audacity 2.2.2 source code is here: GitHub - audacity/audacity at f665e6da2b0bf9d889f65ee59e8d507c4bca2de8
Build instructions for macOS are here:

If there are no objections, I’ll put it in for the next release, but we are very close to freeze, so no promises.

I haven’t programmed before in C++, and besides, I am over-extended as it is.

However, thanks for the offer! :slight_smile:

Maybe this thread can be used as constructive feedback for a future build of Audacity?

It’s in for the next release.

Wow! Now if I could only get Apple or Microsoft to move that quickly on my suggestions!! :laughing: