Macros don't loop through many files in a usable way [SOLVED]

Hi all,
I currently use Audacity 3.1.3 and have encountered a problem with Macro execution.
First some background. My workflow is to buy used CDs, rip wav files, clean up the lead ins and outs, run a macro on all files in a specified folder to normalize levels and save as wav and 320k mp3s. Usually I’m working with at least 50 – 100 stereo files, this time it’s almost 600 files. The macro is to allow me to get lunch, etc. while the machine does the grunt work. This is, after all, what macros should be good at.
The problem is that 3.1.3 does step 1 on all files first, then, presumably, does step 2 on all files, etc. I say “presumably” because my machine begins to slow so much by the time it’s loaded around 30 to 50 files that I cancel the macro. At that point I close 3.1.3 and start Audacity 2.1.2 and run the same macro (chain) and it loads the first file from the folder, normalizes it, saves in one format then the other, closes that file and opens the second one and so on.
My machine is running 64 bit Windows 10 has a 6 core, 3.5 GHz processor, 16 Gb memory, an SSD for both the OS and apps and another SSD for data.
Unless I’m missing something could version 3 be made to process macros like version 2?
The changelog doesn’t mention any changes to macro processing, so I assume that 3.2.3 has the same problem.

Does it take the macro to completion on one file?


No. The first step is to load the file, but it starts to load all the files in sequence. I’ve never let it go long enough to get to the second step. It definitely runs in the following order: load file1, load file2, load file3, presumably until it loads the last file in the specified folder. It presumably would then run step 2 on file1, step 2 on file2 until the last file before moving on to step 3 and so on. The first step (load the file) is the one that defeats the purpose of a macro and would bog down any machine. Ok, maybe not the Star Trek computer, but I think HAL would be toast. :wink:

You are right - something is wrong here. Macros work on one file at a time, then they start over. Have you checked your macro-output directory?

Try selecting just 3 files and see what it does. There were reports back with 2.4.2 that a macro crashed after about 800 or 900 files - but if I recall, it was pretty easy to find exactly which file the macro stopped on. I don’t know if that problem was fixed. If you can’t get your macro to work properly with a dozen or so files, then post your macro here.

Sorry for the delay, I’ve been busy with holiday stuff.
First, I misunderstood the question Koz posted. When I ran the macro on just one file, it appeared to work but I couldn’t find the output file even with Windows Search searching all of both C: and D:. Then I remembered that all of my macros were exported from 2.1.2 then imported into 3.1.3 when I first moved to 3.1.3. So I manually recreated the macro in 3.1.3 and it all worked correctly. I’ve only verified it on about a 12 file run so far. The text of the macro is a little different between the two versions and you know how literal computers are.
So, problem solved! As a new user to the forum, do I need to tag this as solved and if so how do I do that?
Thanks for the questions (which prompted me to dig a little deeper) and Happy New Year everyone!!

Glad to hear that you’ve got it working. I’ll close this topic.