Macro won't run on select files.

I am trying to run a short macro on a batch of MP3s (steps: Amplify, Compress Dynamics, Export as MP3) . The process keeps getting hung up on certain files. When I try to open an individual problem file and run the macro on just that file it won’t run. I also can’t run the standard “Fade Ends” macro on that file. I checked the file’s Permissions under Properties, and it is no different on these files than on the ones that run the macro successfully. But just for kicks, I tried enabling “Full Control,” but that made no difference. I tried to upload one of the culprits, but it says the file is too large (MP3 7-8 MB). I also tried rebooting.

I m using Audacity 2.3.2 on Window 7 Professional 64-bit

What happens if you try to Import one of those “bad” files into Audacity. My guess is that you will get an error message. If you do, tell us the exact and complete error message.

OK, we got a pot going here. I’m betting some of those aren’t MP3 files.

I got a lot of pennies riding on this.


Sorry, I didn’t see the answers to my post until today. Yes, the files are all definitely MP3s. I am able to import the “bad” ones without any error messages, and they play fine. I tried fooling around with the macro itself. For example, I used normalize instead of amplify, and I got it to work. Then when I went back to using amplify, it initially worked on all the files, but upon re-test it hung up again on those same files. Don’t know what to make of this.

Are you able to create a “minimal test case” that you can share with us, to illustrate the problem?