Macro Issues with 2.4.1


First, thanks for the upgrade!

I found that a multiple step Macro only shows the the progress dialog of the first command in the Macro. My Macro has a Compressor Effect, then an RMS Normalize Effect, then a Limiter Effect. When I run the Macro, I see the progress dialog for the Compressor, but then the program seems to hang but I think it it is processing the RMS Normalize and the Limiter, but just not showing the dialog. It seems like it might be showing dialogs for the built-in effects but not the Nyquist effects. This seems to hold true when I run them individually, not within a Macro. Did I maybe mess something up during the install of 2.4.1?

Also, I have a macro that applies the Silence effect to a highlighted section of audio, then does a short jump back a couple seconds, does a play/stop and set cursor and keeps playing. That way I can listen to what I just silenced by starting a few seconds before the silence I just applied. See image of Macro below. I have it tied to my mouse button so I can highlight and just press the mouse button to save time. What happens when I run this (I don’t remember it happening in the prior version) is that the focus of the track that I’m working on jumps to the first track in the project.

It’s not a huge deal, just something I didn’t need to deal with before. Any ideas?



That’s exactly correct. It’s a bug.

The good news is that the next Audacity release is scheduled for not much more than a month, so hopefully it will then be fixed.

The other good news is that you can now replace the RMS Normalize effect with Audacity’s built-in version: