MAC OS Lion - build errors: config.h: No such file

New to the MAC world, so there is likely a very simple and obvious solution.

Trying to build audacity-src-2.0.2
Followed “Building On Mac” from wiki.
From command line build, I get 195 of this type of error.
I tried using Xcode 3.2.6 and got even more.
Tried just compiling “libFLAC” separately and got this error, which is common to all the others:
/audacity-src-2.0.2/mac/…/lib-src/libflac/src/libFLAC/bitmath.c:33:22: error: config.h: No such file or directory
Looks like the lines that generate the error are:
#include <config.h>

Please tell me what I am doing wrong!

Do you mean this page ?

What version of OS X? if you are on OS X 10.5 or earlier, perhaps you should try .

I suggest you use the 2.0.3 tarball or HEAD rather than 2.0.2.

No-one on the Forum currently builds Audacity on Mac so I suggest you follow your own intuition or Google search results as you wish. Note however that you have to use XCode (IDE or its own command-line tools). Command-line building as done on Linux hasn’t worked for years.

If you find a solution, please post it here. If not, please recheck all the Wiki steps and tell us your version of OS X


OS X Lion 10.7.5

I will try 2.0.3. My concern with this is the “minsrc”.
The tar I have with 2.0.2 is fullsrc.
I did not see a 2.0.3 “fullsrc”
Is there one that I missed?

There is no fullsrc tarball for 2.0.3.

If you need all the libraries included (probably you do on Mac) follow the steps here to check out the 2.0.3 tagged release.