Mac Mini

Just purchased the mac mini and cannot pickup signal from mixer or internal mic.We are running USB to mac mini usb 3.0 and 2.0.

Why can we pick up the recordings?

Unless they changed it in the one that came out a week or so ago, Minis don’t have an internal microphone.

You should be able to connect your USB mixer, wait about a count to five and then start Audacity. Don’t do it the other way 'round. Click the microphone symbol and you should find a device other than Built-In Input. That’s probably the mixer.

If it’s not there, close Audacity. Apple (upper left) > System Preferences > Sound > Input. Your mixer should be listed there and the sound meter should bounce if you make sounds.

Where do you lose it?


Hi Koz, it does show up as ‘USB Audio Codec’ in the microphone drop down menu.

And then when I go into System Preferences - and Sound app - there is also a signal appearing in the meter.

But in Audacity, there is no signal coming in when I hit record.

I can get a signal into other sound programs like Audition.

  • And also if I connect the mixer into my laptop, it records okay in Audacity.

So, it seems to be linked directly to Audacity installed on the Mac Mini (I’ve reinstalled it once too to check)

I am having a similar issue. Mac Mini has USB CODEC for input. HDMI for output. Signal is present in System Preferences. Signal is present in GarageBand. No issues with GarageBand with my hardware configuration (get both input and output with no issues) so it appears to be a software and/or Audacity configuration issue?

I have deleted and reinstalled Audacity, including application support files. When I click on Record or try to start monitoring, there is no signal present in Audacity. Inputs and outputs in Audacity are the same as in other audio software on this machine, i.e. USB CODEC for input and HDMI for output.

Audacity version 2.3.0
Mac OS 10.14.3
Mac Mini 1.4Ghz i5 dual core 500Gb HHD 4 GB RAM

Thank you for your assistance.

Depending on what your real life device is, you should be able to send sound back. Does that work? Generate > Tone: Sine, 440, 0.8, 10 seconds.

Play it to the mixer or whatever you have.

Are you using 44100, 16-bit as your sound preferences? No matter what your device says it can do, they can all do that.


Yes. I can produce the tone and can hear it through the output. Still no input. Quality is set to 44Hz 16 bit.

Can also load and play files with no issues.

OK. Problem has been fixed. Audacity did not have access to microphone. Corrected that in privacy settings and all is good.

Thx for all the help.

OK. Problem has been fixed.

Thanks for posting back and telling us how you fixed it. That’s Mac privacy settings, right? That’s just a little wacky. It allows a device connection to exist, but won’t allow a transfer of data.

Where did you go to find that fix?

@silkyjnr … Did this solve your problem?


No. Im not sure what steps I am supposed to go through in the privacy settings.

unclejace, do you mind stepping out your process.

I am still not picking up a signal in audacity but its working fine in audition.