lv2 plugins cannot be enabled because of URLs in locations

I’m using Audacity 2.3.2 on the latest version of Arch, kernel version 5.2.11-arch1-1-ARCH. I installed it via the official package repo for Arch, using pacman. Nothing fancy.

The problem I’m having is that all my lv2 plugins show up in URLs in the plugin activation window and cannot be enabled. This happens regardless of setting the LV2_PATH explicitly. I’m guessing it’s looking in the tti files to arrive at the URLs? Clearly, Audacity doesn’t have a problem finding the LV2 plugin locations, so that it lists them in the add/remove plugins editor. I’m stumped. Any help would be appreciated.

I’m using Audacity 2.3.2 in the latest Arch with the 5.2.11-arch1-1-ARCH kernel. It was installed using pacman, from the community repo. Not AUR.

I noticed that lv2 plugins are seen in the Add/Remove Plugins window, but cannot be enabled upon exit. An error is thrown, in the form of:

Effect or Command at http://whatever.the.url
nameOfPlugin failed to register

Could not load the library

While all the other plugins have system file locations associated with them, all of the lv2 plugins have URLs, instead. Is this why they won’t register? Is there something I’m missing, here?


Which plug-ins are you trying to load?

I’m having this exact same issue.

Pop!_OS 19.10 (Ubuntu 19.10)
Audacity 2.3.2

Trying to load Calf plugins, also tried with and exactly the same issue.

All entries in plugin-registry.cfg show urls instead of file paths. I tried manually editing this file to show the correct file path (eg: /usr/share/calf) but it is automatically rewritten to the url as soon as the add/remove plugins menu is item is invoked.

Calf plug-ins have been problematic for Audacity for a long time. The good news is that the latest version of Audacity runs most of the Calf plug-ins (recent and latest versions) correctly. I think Audacity 2.3.2 may be just a little too old for that fix.

Yes, that’s normal, because (apparently) that’s the “name” that they report to Audacity. Once installed, Audacity can read the actual name of the plug-in, so it will show up correctly in Audacity’s menus, and in the Plug-in Manager.

That’s not a valid web link, so I don’t know which plug-ins you are referring to.