LP Ripping Dropouts on OSX 10.12.6 Audacity 2.2.2

Hi folks

I can’t seem to solve my dropout problem like many of you.

I rip my LPs on OSX 10.12.6 with Audacity 2.2.2.

I close down ALL programs except Audacity.

I’ve followed the instructions on

as much as possible, including:

  1. Reduce screen redrawing: Zoom out to at least the entire length you’ll be recording:
    → Me: Done that.

  2. Turn off Transport > Transport Options > Software Playthrough (on/off) unless it is essential you hear what is being recorded.
    → Me: I want to hear my LPs while I’m ripping so this is a deal breaker.

  3. Increase the default “Audio to buffer” setting of 100 milliseconds in Recording Preferences. -
    On Mac using Mavericks or later, it may be necessary to reduce audio to buffer, possibly to zero.
    → Me: Done that.

  4. Reduce the amount of audio data being written: Choose 16-bit Sample Format in Quality Preferences and set recording channels to mono in Device Toolbar (unless you need stereo).
    → Me: Just reduced from 24-bit to 16-bit … I want 24-bit when I’m recording my own music, but maybe 16 would be OK

  5. Use a local drive with sufficient space: Set the path to the Audacity temporary directory to a local hard drive because these are usually faster than external USB drives. Choose the local drive with the most space. Audacity tells you how much longer you can record for (based on available disk space) in the Status Bar at the bottom of the window.
    → Me: Yes, done that.

Computer and hardware
6. Quit as many other other applications or processes as possible. In particular, stop anti-virus applications scanning the Audacity Temporary Directory. Disconnect from the internet.
→ Me: Done that. I have Sophos and have stopped that behaviour.

  1. Set Audacity to a higher priority in the operating system.
    → Me: I would love to know how to do this on Mac OSX. I use the command line regularly but if this is important, I think it should be available from the GUI, eventually. I really think that it’s important to be able to use all the resources of the PC to do the most important job, the ripping. Please help us.

  2. If you are using a USB recording device. connect directly to a USB port, not a hub.
    → Me: Done that, even though the design of the iMac make that really fucking inconvenient.

So, that’s what I’ve done.

I would prefer to keep my recording settings on 24-bit, but if that’s really necessary I can go to 16-bit. At my age, 78, I probably can’t hear the difference.

I’d be grateful for any help, so we can solve this problem for as many people as possible.

Audacity is still my favourite ripping software & I’ve donated once, maybe twice to show my appreciation.

I’d really love to find the settings for Audacity to take control of the resources it needs to rip without dropouts.



I wonder if re-nicing (prioritizing the CPU) the process would help:

  1. Find the PID:
    ps ax | grep Audac

  2. Look at the nice value:
    ps -fl -C

  3. Re-nice it to the max:
    sudo renice -20

  4. Check that it’s been re-niced to -20, the highest priority:
    ps -fl -C

Mine looks like this:
501 7110 1 0 4:47PM ?? 0:08.87 /Applications/Au 4080 97 -20 … etc

I’m trying it …

Try this one: FAQ:Recording - Troubleshooting - Audacity Manual

My experiments with re-nicing haven’t stopped dropouts.


Thanks for the reply. From your link:

  1. Open Devices Preferences and adjust the “Buffer Length” setting. Reduce the setting to 0 milliseconds.

I had done that already.

  1. If you are recording from an external USB or Firewire interface, open /Applications/Utilities/Audio MIDI Setup and select the device. On the Input tab, make sure that the sample rate and number of channels matches with those chosen in Audacity.

Was set to 2 ch 16-bit Integer 48.0 kHz so I’ve set that to 2 ch 16-bit Integer 44.1 kHz to match my Audacity settings.

  1. Turn off WiFi.

OK, done that.

  1. Mitigate power saving features in Mavericks or later that can interfere with recordings.
    Right-click or Control-click Audacity.app then “Get Info” and enable the “Prevent App Nap” checkbox. This should prevent the Mac putting Audacity into a paused state when it does not have focus.
    A few users have reported that Antipop helps. This prevents the Mac shutting down the audio system when there is no playback.

Not on Mavericks yet.

I’ll report back again.

The next part is important:
“If recording breaks up or does not start, increase “Buffer Length” in increments of 10 milliseconds until recording is smooth.”

There is a known issue on many modern Mac systems, that if the Audacity buffer setting is too small or too large, there are dropouts (clicks). Some systems appear to be a lot more sensitive than others. For systems that suffer from this problem, it’s a matter of tweaking this setting to find the sweet spot.

The recording starts fine and does not break up. It just drops out for 1 or 2 seconds here & there. There are no clicks happening in my case.

Even so, do you recommend changing the buffer size?

I’d suggest trying slightly different buffer sizes to see if the problem gets worse or better. If “110 ms” buffer is neither better or worse, then try 120 ms. Keep going until you see it getting better or worse. If increasing the size only gets worse, then try the other way and make the buffer progressively smaller (90, 80, 70 …). Unfortunately this will take time, but hopefully you will find a “sweet spot” where your system records reliably without dropouts.

Thanks again.
I’ll give it a try and report back.

At the moment, I’m not having any ripping dropouts with a buffer length setting of 110 milliseconds.

Can anyone explain why that tiny buffer is so important?

Thanks Steve.


Sorry I don’t know why the buffer size is so critical. All that I know is that Apple changed something a while back, and for some users, the buffer size became more critical than it used to be.

Well, after another few rips, I appear to not be getting any dropouts, even when I have other programs open.
As I said, my buffer is presently 110 milliseconds and my problems have disappeared.

I was extremely skeptical that the buffer setting was my problem, but at the moment, that is the only thing that appears to have remedied my situation.

Many thanks for your help, Steve. I really appreciate your efforts.