Loud speaker pop when starting Audacity

Hey Y’all,

I’m running Ubuntu-Studio 19.10 64bit with the kubuntu desktop, audacity version 2.3.2-2 installed from the Ubuntu official repo.

When I start audacity, my speakers make a very loud pop that scares my dog. (and me. :slight_smile: ) This has happened with the last couple versions of audacity until this recent version. The current version I have was fine until I changed the recording device from default to pulse and back. It wouldn’t make a noise at all at start, left my settings alone, etc. When I changed it today, It popped each time I did (from default to pulse and back) and has popped each time I’ve started the application since.

I have noticed that the pop occurs when audacity resets my audio settings. I also noticed that the pop happens when I run ‘alsactl -restore -f ’, making me think the root is either alsa or pulse…

Has anyone solved this issue, or would anyone know how to tell audacity to not reset audio settings on startup?