Lost my external mic connection on both IMac and MBP

Both systems were running fine before upgrade to 2.0.2, now I have no external mic input. I have tried several mics on both systems, same results.


Neither MBP nor iMac have Mic-In. I think they will both support headset systems like the headset on an iPhone, and they will both support any USB or Optical Digital Audio.

And Built-In microphone.

Apple > System Preferences > Hardware > Sound > Input. If it’s not there, you don’t have it. Audacity uses the computer (Mac System) services to connect to devices.


Both show line in. It doesn’t matter what I plugin to it. Microphone or audio from a soundboard. They both worked fine before the upgrade to 2.0.2. Now the line in is still there but no sound is coming in


Check in:
Apple > System Preferences > Hardware > Sound > Input

The connection to the sound board should work. That’s how I record voice and sound material for the editors at work.

Some people confuse recording sound with being able to hear it. You can record sound performances without being able to hear what the computer is doing. It’s dangerous, but it’s what you do when you have an important recording and you left your earbuds home.

When you’re in Apple > System Preferences > Sound > Input and you have Built-In Line-In selected, play music on your mixer and see if the bouncing blue ball sound meter jumps.

Does your Mac look like this?



Yes it does. I have been using Audacity for a few years to record and edit with. Like I said, it has ran fine on my Dell PC and both MACs. The Dell still works, and I did a PRAM reset on the MBP last night, still nothing. If I switch to the internal mic I can record but I cant use that to record with. Do I need to go back a version or is there a patch? I cant be the only one that this has happened to???

No you’re not. It’s quite a common problem that recording suddenly stops working.
It’s also common for such problems to occur directly after updating the Audacity version, but it is extremely rare that problem is caused by upgrading Audacity.

Almost always the problem is due to some change in the computer sound system or sound system set-up, but often the user has not used Audacity for a while, so they update it, and then discover the problem. Very often the problem is incorrectly attributed to Audacity, because that is the one thing that they know they have changed, but that causes them to look in the wrong place for the problem.

Another thing that makes it unlikely to be an Audacity problem is that there have been virtually no changes to how Audacity records for a long while, so unless you were using an ancient version of Audacity, then Audacity’s audio engine will be the same as your old version.

You’re attention needs to be on (1) the computer sound system is set up correctly and working. (2) Audacity is set to record from the correct input (see here: http://manual.audacityteam.org/man/Device_Toolbar ). You can’t do (2) until (1) is right.

Not sure what to do. I can uninstall and install a older version. I can try to restore thru Time Capsule to the point before I upgraded on Sat. Seems odd that a software update would mess with the MAC hardware also.

So are you absolutely sure that Sound Preferences showed an external mic input before you upgraded to Audacity 2.0.2?

– Bill

Fourth time now. We need you to say the words “I went into Apple > System Preferences > Hardware > Sound > Input and checked the sound meter there.” Leave Audacity closed. Audacity can only work with the sound that the computer supplies to it.