Lost most of my tracks and days of work in a project. Please help!


I’ve spent days working on a musical composition and have done hours and hours of editing, with numerous tracks created within the project to get the end result I’ve been working towards.

I’ve hit ‘Save Project’ and ‘Save Project As’ numerous times to ensure my work was saved. Tonight I left the software open and my laptop on, which went into sleep mode, while I went out and had to do some things outside of the house. This evening when I was ready I had to boot up my laptop because the power source was unplugged but it did not shut down entirely apparently.

I brought Audacity to the front of the screen and looked at my project. I suddenly realized that there were only 3 tracks remaining in what was a 20 or more track project!!

I tried hitting edit undo as many times as possible but it did not restore any tracks. I then decided to close out without saving and reopen - hoping that I would find the latest save. But unfortunately when I opened it was still a project with only 3 tracks…

Please advise!! This is unbelievably disheartening.

Quite bizarre, indeed! I assume you also tried “redo”.

So in 3.3.3 if you closed the project without saving the database software should have automatically rolled back any of your changes.

As you do both “Save” and “Save As”, you should have an alternative backup.

For me, whenever I do save, I also close the project, then reopen it, this flushes out the space required for the UNDO buffers and makes processing a little more efficient. Although I don’t see how this might have changed your outcome.

That is correct, I clicked undo and then redo a number of times trying to get back to when all my tracks were there.

Unfortunately when I’ve done ‘Save As’ I’ve just saved it as the same file. Won’t make that mistake again. I stupidly thought obsessively “saving”, or saving as, would ensure I wouldn’t lose my work…

I’m all ears if you or anyone else has a fix for me. Right now I’m hopeful that I can rebuild using the project data files. Not sure how that works but it’s all I’ve got at the moment.

So if you are running 2.4.2 with .aup files and _data directories, I am unable to comment.

Personally, I feel the .aup3 unitary database project structure is more robust, but I know there are others that may disagree. (Hint: They are wrong).

For future reference I would advise using File > Save Project > Backup Project rather than Save As

Backup has the advantage of letting you save in a different project name while enabling you to continue to work in your originally named project (Unlike Save As, which switches to the new name).

I would also advise saving differently named backups at different key stages of the project.

But sorry, like Jademan I am totally baffled by what you report …


Just checked and I’m on 2.2.2 if that helps at all

Yes, it is truly bizarre and confounding! I mean, theoretically, if saved I could reopen to the last saved version, no? It seem saved in a way that I DID not do… I would not delete two dozen meticulously edited tracks and then hit save…so wtf?

I checked and I don’t see that “backup” option so perhaps the version I have doesn’t have that functionality, idk. But yes, absolutely saving to a new name in the future. The thought of recreating everything I’ve been working on for days is a tough pill to swallow. And some things were happy accidents so I don’t even know if I could get that lightening in the bottle again…

Do you happen to know if rebuilding from data project files (the .au files) is an option?

You are using a fairly old version of Audacity (that’s why you don’t have the backup command) - have you considered upgrading to the latest version 3.3.3 which you can get from here:

Sine 3.0.0 the project structure changed - it is now a single consolidated SQLite databas rather than the collection of lots of little .au files. This is more robust for most folk and IIRC recovery was also improved too at that stage.

This will not help with your current damaged project - but may well help you in the future.

Do you happen to know if rebuilding from data project files (the .au files) is an option?

Sorry but I don’t think you will have any success with that.

This topic was automatically closed after 30 days. New replies are no longer allowed.