Lost minutes of recording before saving

Twice in the last 5 times I have recorded hour long presentations there were tens of minutes of silence at the beginning of the recording. The recording is done via a USB input to a laptop running Win8.1 with the latest patches. Audacity is 2.0.3. I start recording a few minutes before a presentation and stop it a few minutes after. I do not change anything during the recording. At the beginning of the recording I always verify Audacity is recording.

The problem occurs at the end of the recorded presentation when I click on Save Project As… My usual process is to create a new folder with the date in the name. I then save the project in this folder with the date and name of the presentation in the file name. Until recently this was never a problem. Twice recently I get an error message that “Audacity does not have permission to write into the folder or that there is not enough space”. Audacity does have write permission as it just created the folder. There is 170+ GB of free space on the disk.

At this point I check the recording and surprise: the first tens of minutes (45 minutes the first time and 25 minutes the second time) are silence! At this point I save save the project as a compressed file but this does not restore the missing minutes. Audacity just saves the minutes of silence at the beginning of the file.

I have tried various saves, copy/past to a new file, etc. to recover the missing minutes. I have used Task Manager to cancel Audacity with the hope that the Audacity Recovery will restore the missing minutes. Nothing was successful in restoring the recording.

I have looked at the FAQ for help. There is an FAQ which discusses a recent fix in 2.0.3 that saves silence if a block is overlong. Huh? Why should a block be overlong? My problem is not one block but 10s of minutes of silence. Maybe did this change did not precipitate my problem but it sure seems coincidental. And I do not get any messages that there have been overlong blocks.


  1. How can I recover the missing recording when this happens?
  2. I believe the recent change to Audacity has an unintended side effect. Or if Audacity is saving silence by design then this is not a good design. There must be a recovery tool/process provided. It is not acceptable that I lose 25 to 50% of a recording with no obvious way to recover it!!!


Hi Steve,
The current version of Audacity is 2.0.6, which is available here: http://audacityteam.org/download/
There have been many bug fixes (and feature enhancements) since 2.0.3, so updating is recommended.

When you start the recording, do you see a waveform appearing in Audacity?

When you stop the recording, do you check it in any way before saving and closing Audacity?

Where are you saving to? Is it an internal hard drive, external, network drive, USB caddy, something else?

At the beginning of the recording I always verify Audacity is recording.

By doing what? I use the bouncing red sound meters which I make really large.

Do you get the accumulation of blue waves, too?

If you have both of those, then Audacity thinks it’s making a good recording.

I don’t know of any reason why Audacity would “forget” about parts of the show. There are two “tricks” for making a recording: Open a blank Project and Save it immediately. After that you can Save instead of Save-As and Audacity doesn’t have to make a Project out of whole cloth. It’s already there.

Export as a WAV file instead of, or in addition to saving an Audacity Project.

As far as rescuing an existing show, that is a little bit of a sore point.

a new folder with the date in the name.

How do you write the date? It’s exceptionally good practice not to use slashmarks in a filename. Today is 2014-12-01 (ISO format), not 1/12/14. That might be where your permissions problem is coming from.

When was the last time you did the exhaustive version of your virus scan? The one where you can’t use your machine for fifteen minutes.


Also, the path to the file (including not only the file name itself but the names of the folders the file is buried in) is limited to 256 characters.

Sometimes Audacity hits AUP file saving issues when there are really none. Try Export as WAV instead.

Clean reboot the computer to fix AUP file saving. On Windows 8.1 that means use the WIN + X menu to Shut Down, wait a few seconds then start the computer.

Let us know your answer to Steve’s questions. Also look in the “Directories” section of Audacity Preferences and tell us what the Audacity temp directory is set to.


Thanks for your reply.

Yes, at the beginning of the recording I always verify Audacity is recording by looking at the blue waveforms. I have been using audacity to do these recordings for 2 years. I know what a good recording should look like.

The following in bold is from the Release notes for 2.0.3. It seems like I’m getting “Missing Audio Data Block Files”. When I have this problem the error message that I see is that the “File is too large or you do not have permission to save”. I do have permissions and the file is too large because I can only save it compressed. I have only seen this message the two times I have had silence at the beginning of a saved recording.

Problems reopening, saving or crashing in projects

The following problems are very rare, but have the potential for losing data. The developers have not yet been able to reproduce these problems so please write to our feedback address if you encounter any of these symptoms.

When attempting to reopen the project normally:
The .aup project file was not saved (or incompletely saved, giving a “line number” error).
Audio that was there previously is silenced.
“Missing Audio Data Block File(s)”, “Problems Reading Sequence Tags” or “Orphan Block File(s)” errors are reported. If you see these errors, please choose the options to “Treat missing audio as silence” or “Continue without deleting” the orphans.

Thanks for the suggestion to save as a WAV.

My date convention for file names is YYYYMMDD. I never put slashes in the date. With this convention the names sort consecutively in Windows File Explorer.

It has been a while since a full virus scan. Note that on the day I had problems this was the second recording of the day. In the morning I had completed a successful recording of well over an hour. The afternoon recording had a problem. Between the two recordings the laptop was turned off and it was only turned back on just prior to the afternoon event.

My date convention for file names is YYYYMMDD.

That’s one of the ISO accepted options. And yes, it’s cool because it sorts perfectly without the system knowing what a date format is.

You do seem to be in the rare atmosphere of doing everything right and Audacity still insists on damaging the show.

From the first post:

Audacity does have write permission as it just created the folder.

Audacity created the folder or you created the folder outside of Audacity?


To cover all possibilities, I recommend you try a proper shut down as I suggested in Lost minutes of recording before saving - #4 by Gale_Andrews

As Steve asked, where are you trying to save the project to? Please give us the complete path to the file.

Where is the Audacity temporary folder? I suggest setting the Audacity temporary folder to the local drive that has the most space available. Do not use an external drive for the temporary folder.

Do you have Norton? In that case you must turn off its Windows temporary file cleaner or it may delete your recordings. To make sure your recordings are not deleted, in Audacity’s Directories Preferences, type a valid folder location that does not have “tmp” or “temp” in its name. Or do as Koz suggested and File > Save Project As… before you record.

Do a SMART check on the drive you are saving to.

Also right-click over that drive > Properties, then choose the “Tools” tab. Run the error checker there (it will run when you reboot).

Have you seen a message that says that? If you still have Audacity open in the failed second session, please open Help > Show Log… top right of Audacity, save the log file and attach it. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

If you have since restarted Audacity, please open the AUP that has the silenced recording then attach the log as above.

That is a paraphrase, not what Audacity actually says. Do I understand correctly that Audacity saves the AUP project file and _data folder, despite giving you this error message? Or does it fail to save an AUP when it gives that error, and then saves without error message when you try again?

To be clear, do you mean you can use File > Save Compressed Copy of Project… without seeing an error message? I would not expect that would restore silent audio because the data has already been damaged.


This has been frustrating doing it right and the same way for more than a year. Parts of each presentation need to be copied and exported to mp3 for posting on a web site. I usually do the extract and then export and post later the same day from home. So when some of a recording is lost I can’t post that to the web site. Client is understanding but it is a let down.

Audacity creates the folder as follows. After recording I create the folder in Audacity by going to “Save As” then up one level and create the new folder on the laptop. I only use letters and numbers no symbols in the file name. The file name is never more than 50 characters. After successfully saving on the laptop I copy that folder to a cloud drive.

In the most recent case I had successfully saved an hour recording in the morning, turned off the laptop, turned it on in the afternoon, made an hour recording and then went to save it using the process I just described. But it failed with 25 minutes of silence.

Because I have been doing the same thing for more than a year some recent change has impacted this process seemingly randomly. I need advice on troubleshooting / debugging. This includes thoughts on how I might force the problem in a controlled way. I can’t impact my client’s recordings.



I wrote a long post Lost minutes of recording before saving - #7 by Gale_Andrews on things you could try. Have you tried those?

We’re still waiting for you to reveal the exact path you are saving the project to and the exact path of the Audacity temporary directory. The latter in particular could be the answer to the problem. If either path is private because of the client’s name, please just change the name part of the path to “freddy” or something but give us the rest of the path.

Could you please post the log as requested? We can’t see that unless you post it.

Also you should think what you changed yourself. Did you install a new security suite? New disk management utilities?


This has been frustrating doing it right and the same way for more than a year.

We’re still waiting for you to reveal the exact path you are saving the project to

Thanks for the details, but you need to follow us when we direct you to do things. We have to keep your machine in our heads as well as troubleshoot and that’s a little rough if you wander off.