Lost Headphone Jack, Added USB "Jack", No Internet Volume

My headphone jack (Dell Inspiron, Win 8.1) stopped accepting the plug, so I got a USB stereo sound adapter for the headphones. Audacity only lets me record internet audio through the “headphones”, so I was always adjusting the headphone volume before beginning the record process.

Once the headphone jack went away, so did any record volume on Audacity. The monitor speakers are fine, and the audio through the USB adapter actually sounds better. But no volume on Audacity. I loaded the new version 2.1.0, and tried the “rescan devices” bit.

The drop-down menus show MME. For input the choices are 1) Microsoft Sound Mapper - Input . . . 2) Microphone USB Headphone . . . 3) Stereo Mix - Realtek HD.

I’ve tried various combinations, but nothing. I’m sure it’s something simple. BUT WHAT???

Self-Recording goes through the analog soundcard. USB services don’t. So that’s where your sound went.



In other words, you will have to change host to Windows WASAPI (loopback) and choose the USB Audio CODEC (loopback) or similar as the Audacity recording device. See the link Koz gave.