Lost data while program still opened

I recorded something with audacity left it be while I was away came back and tried to save it but came up with
Error Saving Project
Could not save project. perhaps… is not writable or the disk is full

first of all the disk isn’t full, on my desktop second I saved a file just before recording this one.
I attempted to save it twice when the waveforms and sound suddenly dissapeared from the file. I did edit undo and even my first recording no longer shows. I’ve been looking for a solution for this because I don’t want lose this. auto save was useless, it saved after it dissapeared, I think. I copied it to my desktop just in case but I’m not sure how to make sure. I’ve left the program opened for now because I can’t save it, I tried exporting as and .mp3 and it obviously shows up blank. How does this even happen, I don’t know, that’s why I bringing up the problem, if anyone could help that would be great.

How long were you gone and did the machine go to sleep?
What kind of Mac and which OS? I’m typing on a Mini with OS-X 10.9.5

Did it try to save a Project with a date in the filename?


Which Audacity? All three numbers. I’m using 2.0.6.


sorry, I have Audacity 2.0.3, OS 10.9.5, Usually when I put it to sleep with audacity open like that it doesn’t do any harm, I have done it before, i’ve just been lazy and I’ve been saving it as aup files instead of exporting it. I was gone to work for about 5 hours but the program has been open like that for longer before and I’ve never had this issue.

I’ve been saving it as aup files

Those are dangerous words. There is no Audacity AUP sound file format. The AUP file is a list of instructions that tell Audacity what to do with all the stuff in the _DATA folder of the same name. They’re useless without each other. You can’t send send a show to someone by emailing the AUP file.

first of all the disk isn’t full

We warn people that “plenty” is not a drivespace value. Actual numbers are good. My MBP has a 250GB drive with 124GB available. Were you recording for the whole five hours?

The .aup file with the data of course, mostly because I didn’t have time to export and fix up the audio. No this is a 22 min recording and now instead of actually having sound it’s 22 minutes of nothing.

Though probably not relevant, 2.0.3 is old now. You can get the latest 2.0.6 from http://audacityteam.org/download/mac.

If the waveform disappeared when you saved, the error Audacity gave is probably legitimate. I suggest that from Finder you do Go > Utilities > Disk Utility then Verify Disk and Repair Permissions.

Do you have a known, good external drive? You could perhaps copy the temporary data to that drive then drag a few of the AU files into Audacity from the new drive just to see if there is content or only silence.

If there is content then you may be able to recover the data from the temporary folder by following http://manual.audacityteam.org/o/man/recovering_crashes_manually.html.


I’ve repaired my permissions recently, maybe two days ago, I’ll do it again. I didn’t realize that there was a new version out but it shouldn’t really make that much of a difference but I’ll change to it once I figure out how to fix this. Also I attempted to save it and all it made were data folders that were empty ( zero bytes) , I wasn’t successful in saving this one but the previous one that was recorded the same day. I’m not sure if a crash fix will help considering I still have the program open with the empty 22 minutes on it. I had a feeling that I solution wouldn’t be found for this problem considering no ones probably had this before. I would really like to be able to get this data back though, somehow.

I’ve repaired my permissions recently, maybe two days ago, I’ll do it again.

You can have permissions issues if you do a security upgrade or in some other way change the system at the OS-X level. Generally, installing applications or doing production won’t do it. Permissions are a system level setting.


I attempted to do recovery but lacking when it says “press end on your keyboard” but this doesn’t change the fact that I don’t have a file to recover the data for. The files that I have are data folders with nothing in them and a copy of my previous recording, I don’t think i can do anything with them. Some how audacity lost data while it was opened, is there no way to take those pieces and put them back together. I couldn’t save it and the original audacity file is open with the right length, just no sound. I need to know if there is any way to fix this at all.

Obviously you can’t use those.

But what about the Audacity temporary folder? Look in Audacity > Preferences… then the Directories section. Is there a “Project” folder there that contains “d” and “e” subfolders?

Where are the pieces, exactly? If they are AU files, do File > New in Audacity then drag a few of the AU files into that new window. If the AU files contain pieces of the recording, then you can try recovering them using http://manual.audacityteam.org/o/man/recovering_crashes_manually.html.

If the data is there, and as long as you had not started editing it, it should be recoverable.

If it was a stereo recording, you may get some chunks of the recording with the channels transposed.


This has yet to be resolved by anything so far, I fear for closing the program because there is no actual save file. Is there a way to use the auto save? probably not going to work. If there is nothing that can be done I would like to know, I will be disappointed though.

That’s the difficulty I the files don’t seem to be there. Audacity preferences is grayed out on mine for some reason, this seems like a lost cause.

The manual crash recovery, what do they mean by this

Click after the end of the topmost track.
Press END on the keyboard.
Click Edit > Paste and the cut track will attach to the end of the topmost track.
Repeat as necessary to join all the tracks onto the topmost track.

I can’t quite understand what this end on the keyboard is.

That’s hard to tell in this situation, but if there is any non-silent audio data that Audacity is using but can’t read properly, you can force quit Audacity (Command - Option - Esc) and that data should be retained. Obviously if you know there is non-silent data that you can use for a recovery you can copy that data to somewhere safe before you quit.

Please try pressing the yellow Stop button then see if you can access preferences.

Have you knowingly been into Audacity Preferences and changed the Audacity temporary folder in the “Directories” section of Preferences? If not, open Finder, use the Go > Go to Folder menu and type:


Look in the subfolders in “folders”. Somewhere there should be a folder called “audacity-” that contains the temporary subfolders that Audacity is presumably reading from.

You can press K on your keyboard instead of END.


Preferences has been grayed out for me for as long as I remember, don’t think I’ve every been in there, odd, I’ll try the recovery one more time and if that doesn’t work I’ll just give up.

We don’t make Audacity that does that.

We can only help you with Audacity obtained from us: http://audacityteam.org/download/mac.