Lost audio in 2.0.1 testing exports skip in iTunes

Split from https://forum.audacityteam.org/t/audacity-tracks-stop-playing-in-itunes-after-3-minutes/38117/1

Just wanted to test… :unamused:

Audacity 2.0.1 on OSX 10.9.5

Audio was OK, I was playing soundcloud. I wanted to see if I could reproduce this error.

  • OSX was set for 44.1/24 bit. All audio from the browser or itunes gets resampled automatically by Core Audio if needed. This works perfectly with all programs.

  • Opened a 4 min. wav (24 bit/44.1 KHz) in Audacity. Export to mp3, VBR, quality 2. Didn’t check if it plays in Audacity.

  • Opened in iTunes. Played OK till the end.

So, no error reproduced under Mavericks. But then:

  • No more audio out from Audacity.
  • Checked System preferences/Sound
  • Checked and reset Midi/Audio setup.
  • Still no audio.
  • Restarted.
  • Itunes still OK playing the export. Finder plays mp3 and wav. Browser has sound too.
  • Audacity still no audio out. Meters show output, but all I hear is a click when starting and a click when ending. Restarted Audacity, didn’t help


21/04/15 01:21:05,451 Audacity[29470]: PScurrentwindowbounds: CGSGetWindowBounds returned error (1001) - repeated ca. 200 times over 24 hours.
21/04/15 01:21:05,452 Audacity[29470]: PScurrentwindowbounds: CGSGetWindowBounds returned error (1001)
21/04/15 01:21:05,615 Audacity[29470]: error [1000] setting colorSpace to Kleuren-LCD colorspace
21/04/15 01:21:05,660 Audacity[29470]: _initWithWindowNumber: error creating graphics ctxt object for ctxt:0x913b, window:0x1448
21/04/15 01:21:05,665 Audacity[29470]: _NXPlaceWindow: error setting window shape (1000)

These seem unrelated to audio. No other interesting lines. Of course, since Lion, the logs have become fairly useless.

Any other things I can test or report?

Reset everything to 44.1/16 again and restarted. Audacity plays again.

I suspect that setting to 24 bit and opening a 16 bit wav produces this strange error. Need to do more testing.

Thanks, Cyrano. The loss of audio (just a “click”) is known about even in 2.1.0 but not everyone experiences it. Do you have a portable Mac?

The click is believed to be when Audacity can’t restart the sound system. Playing audio in QuickTime is often said to restore audio in Audacity.

Can you retest in 2.1.0? Did the Audacity track for the imported file show 32-bit float, and was the Audacity project rate 44100 Hz after importing the file?


I tested in 2.0.1.

Maybe the reason was that I was playing with some interfaces before I tested the iTunes problem. After reaffirming settings [also in Audacity’s prefs] it resolved itself.

Mac users are used to the auto-resampling of Core Audio. So we don’t always notice wrong settings, since the system plays anyway. The same problem appears in Reaper. All other DAW’s behave well and never show that problem.

And yes, it’s a 2009 Macbook Pro (C2D, 2.5 GHz). One of the family that has broken Firewire chipsets (Agere). These work perfectly with harddisks and camera’s, but are a real PITA with audio interfaces. Interfaces do not work at all, or stutter badly, unless you put a harddisk controller (or active cable) in between the Mac and the interface.

And thanks for splitting of this rant :smiley:

Dunno what happened…

Just opened Audacity 2.0.1 and the problem is back. No sound in Audacity, just clicks at beginning and end.

But this time, no sound in Chrome (from soundcloud) either. Sound Forge, Reaper, iTunes and the Finder play normally.

Quit Audacity. Sound is back in Chrome.


Sound is back in Audacity. All other apps play too.

Settings haven’t been changed, still 16 bit, 44.1…

I would go back to 2.1.0 for production use, which has a later version of PortAudio, but I don’t think sample rate or bit depth is the issue.


I agree. But Console is useless. nothing in the logs.

I think it’s a stall somewhere in Core Audio.

Thanks, Gale. Testing IS production here :smiley: