Losing/Lost Audio

I’ve been using Audacity for a quite a while now for my YT channel and have never had the issue I’m going to write out below but of recent I’ve been hitting a few problems which have caused me some major issues. Today it happened again, so I hope someone can help fix it. (Note that this is not the first time this has happened).

Today I recorded a video which was around 30 minutes long. 2 footage sources I recorded were fine and both were at or around the 30 minute mark which is cthe correct finish time. Sadly my Audacity voice recording was is at a total length of 17 minutes. This should not be because when I go to record a video, the audio and Audacity is always the first thing I start with, followed by the footage.

Somewhere and somehow, Audacity is cutting out and removing parts of my audio and simply not recording them. I have not changed anything since I started my videos and it all worked fine until maybe mid Dec 2015 (give or take). I’ve not touched any of the settings and all I’ve ever done is hit record but now it seems to cut out a whole 15 minutes worth of audio recordings.

I’m using Audacity 2.1.1 on a Mac OS X El Capitan 10.11 with a Blue Yeti microphone. If you’d like anymore information on settings and so forth, please just ask.

Can anyone explain why this happened and is there anything I can do to stop this from happening again because it’s completely screwing me over. Thanks.

So you are not recording the video while recording the audio, but recording the audio only?

Has Audacity stopped recording after 17 minutes, with neither blue Pause button or red Record button appearing depressed?

What is the location of your temp folder (see Audacity > Preferences… then “Directories”)? If you save an Audacity project to your Desktop before recording, does the problem still happen?

Have you shut down and restarted the computer since the problem started?


No I’m recording everything all at once. Capture device, and wedcam via QuickTime and then Audacity. Only thing I’ve changed recently is the use of my webcam via QuickTime but the issue still happened once and while before I made this change.

No Audacity does not just stop. It seems like it is simply removing chunks of audio from areas which then equal about half of my audio that should be recorded missing. Example would be the stuff I recorded yesterday. Both the capture footage and webcam showed they were in use for 20 odd minutes, yet the Audacitys time bar at the top aid around 13 minutes when I looked across at my computer. This shouldn’t ever be the case because I start all 3 processes within at least 20 seconds of each other. On top of that Audacity is the first thing I start everytime so this should have the highest run time.

I haven’t changed the save process, but when I import all content into FCPX, the footages are 30 minutes long, yet Audacity audio is 17 minutes long with random areas of audio missing.

/var/folders/sd/3yz2pw5d10xfmbxfncm16dzm0000gn/T/audacity-Nozza - This is the location of my Audacity temp files and yes my computer has been restarted numerous occasions during these issues.

Why not record video and audio in QuickTime or Final Cut Pro (if that is what FCPX is)?

What are your Mac specifications from Apple logo > About this Mac? How much disk space is it showing? You need hundreds of GB’s before you start recording audio and video.

If you have Final Cut Pro open, quit it until the editing stage.

Are you using an empty USB port for the Yeti? You should not use a USB hub connected to the computer.

What happens if you only record audio?

So what happens if you save a project first to your Desktop before recording?

At Audacity > Preferences…, Recording section, what is the value of “Audio to buffer”? If it is at 100 ms, set it as low as it will go consistent with recording starting off correctly. If it is already below 100 ms, try increasing it.


Well I hadn’t thought of that until you’ve just mentioned it but I’ve literally only started using QuickTime for my visual footage as of this video and the issues I’ve posted. I could try but I’m concerned if something went wrong, I’ll lose both audio and visual footage if something happened. Where as I like to have all 3 processes separate just in case. And yes FCPX is Final Cut Pro 10 :wink:

I’ve got 900GB space free but everything is saved onto a 4TB hard drive.

Only things ever open and being used when I record are GameCaptureHD, QuickTime and Audacity.

I have 4 USB ports/slots on my iMac and yes one is being used for my Yeti as it’s a USB plug-in and use microphone. I used to use a Blue Snowball before that and never had this issue.

I haven’t tried this yet so I’m not sure. Though when this happened last time, I was confused. So what I did was keep the Audacity window up on my screen while I recorded and it didn’t remove anything. Kind of thing where me watching it throughout the process stopped it from doing it lol

Well when I’ve hit the stop button, I simply export the file into a AIFF. file and it auto saves to my desktop. From there I move it into my HDD. After that I just close the program.

Buffer is set to 100ms. I’m not too sure what to set it to, so any recommendations?

PS; I’ve attached an image to help as a visual aid of what’s happening. The 2 green bars are the audio files. One’s names 'TR_Part 13_Audio" - This is my Audacity with Yeti recording. The other is ‘TR_Part 13_Visual’ - This is my webcam recording with the wedcam also captureing my audio.

Can you see that in certain areas, and this is only 1.30 into the video I’ve had to cut and place my visual audio into the missing sections where Audacity has not recorded. You can also see that as you go along the both green bars, the audio wave forms do not match when they should. Showing that Audacity has cut-out and not recorded areas of audio yet my webcam has picked all 30 minutes up.
Screen Shot 2016-01-10 at 12.32.44.jpg

As the message says after you post, your post is held for moderation and will appear after it has been approved. Moderation is removed after you have made sufficient posts.


That could be significant. Quit Audacity and Prevent App Nap in Audacity.app.

I was suggesting you actually File > Save Project As… to your Desktop before recording, even though you don’t need to do that. This would test whether a problem with the Audacity temporary directory in /var/folders/ was the cause.

Set it to 0 ms and see if it will start recording. If not, increase it in 10 ms increments until it does start recording.


I’ve just ticket the Prevent App Nap box. I have a feeling this could be the issue. I’ve also just tested out using QuickTime with using my Yeti as audio source and it worked ok. Only thing that annoys me about QT is that the files sizes are massive. My 30 minute video yesterday was 34GB in size which is stupid.