Loopback recording with noice

I fail to record with the loopback function on my windows 10 laptop. Audio played on my computer IS recorded, but it is ruined by a screeching loop of clipping noice. How to get rid of this noice?

The settings i used:
Windows WASAPI, input - Speakers (Realtek High Definition Audio) (loopback), output - Speakers (Realtek High Definition Audio), Recording Channels - 2 (Stereo) Recording Channels. (I got these instructions from a youtube video (https://www.youtube.com/watch?v=Lla74qPiGQ8) and saw the same instructions on the audacity wiki itself, if i’m not wrong.)

How should i get rid of this noice? much thanks in advance!

Look in the Windows sound control panel and ensure that none of the recording devices have “listen to this device” enabled.

Also, in Audacity: “Transport menu > Transport options”, ensure that “Software Playthrough” is not enabled.

Yes! Thanks Steve, it works! The transport settings was the problem indeed. The only slight problem i have now is that the recorded audio is nearly clipping all the time.

Much thanks again.

Try turning down the playback volume in the Windows mixer.