Loop effect noise when recording

I’m new to Audacity, so after using it a few times to transfer cassettes to PC, I decided to record my voice and try out the effects. Everything seemed fine, but I didn’t want to save my efforts so I closed the program.

Next time I came to use it to record a voice track, there was a helluva nasty noise when I pressed record. It sounded like a crescendo of delay and reverb etc. on a loop, making it impossible to record anything.

I closed the program and rebooted my PC but the same thing happened. My next step was to uninstall Audacity, looking for any associated files too. Having done that, I installed it again (from the Audacity site) but the noise still persisted. So I uninstalled it once more and installed again, same problem.

Everything worked fine before, so I wonder whether I’ve missed uninstalling any little files (though I couldn’t find any). Could there be another reason ?

I haven’t installed any other programs since, so I wouldn’t think its a compatibility issue.

Any ideas ? Thanks !!

Try unchecking “software playthrough” in Audacity preferences : recording …
https ://manual.audacityteam.org/man/recording_preferences.html

Thanks Trebor ! It worked first time - problem solved !