Long pause on tracks exported after the first track

I am having a problem where all tracks exported after the first track have a long pause before any audio actually plays in them. The first track exported does not have this long pause. I’ve tried configuring settings, disabling extensions, as well as exporting the audio tracks in a different file format, but to no avail. This problem is occurring on Audacity 2.4.2 in Windows 10. I do not have this problem on Audacity 2.3.3 in Linux, which means that bug this could be a widespread issue with Audacity 2.4.2. Please Help! :angry:

Are you using “Export Multiple” based on “tracks”?
How many tracks in the project?
What are the start / end times of the tracks?
How much silence is there at the beginning of each exported file?

Yes, I am using the export multiple feature based on tracks.

I have a variety of projects with a variety of tracks with this issue, but on average, I have 6. Tracks can be as long as 12 minutes due to this long silence

It depends on each track. I have found as little as 2 minutes of silence, as well as more than 5

Do your tracks have empty space before the audio starts?
There’s an option in Preferences to select whether empty space before the track starts is included as silence, or ignored:
Ignore blank space at the beginning

There is about 0.25 seconds of silence on each track before they start

And that setting you mentioned, is disabled on both my windows and linux computer. However, my linux computer, which runs audacity 2.3.3, does not add that long pause to the tracks exported on it.

I think you will need to provide more information.
Describe in detail, step by step, how I can reproduce the problem.

Step 1: Create a tone. It doesn’t matter what length and what duration.
Step 2: Starting from the end of the tone, cut a section out of it. It doesn’t matter what length you cut out as long as it isn’t more than half of the tone.
Step 3: Create a new track.
Step 4: Paste the section of the first track you cut out on to the new track you just created. The start of the section on the new track should be inline with the end of the section on the first track.
Step 5: Use the export multiple tool to export both of the tracks.
Step 6: Playback the second track. Is there a delay in it before any audio plays?

This procedure should reproduce the issue I am talking about.

Enable that option.
Does that fix the problem?

Hey, that worked! Thank you! Audacity 2.3.3 must have had a bug with that setting…