Long audio track does not export fully with FFmpeg (repeatable)

I hope you can offer some advice.

I’m using Audacity 2.4.2 on Windows 10 Pro 21H2

When exporting audio using FFmpeg & the files are over 2.5 or so hours long the resulting file is only a fraction of the original.

I have been trying to export a 3hr+ movie file using FFmpeg to eac3 but the file I get is 9mins long.

This has happened me several times before with long 3 - 5hr audio files exporting using FFmpeg to different formats & the result is the audio is not fully exported.

I have never had any problem with smaller files or file up to 2.5hrs or so but once I go over 3hrs + I can be guaranteed the audio won’t export fully.

I have been looking for anyone else with this issue or similar but maybe I’m not using the right search terms as I can’t see anything like this.

The command I’m using is for the export in Audacity is:

ffmpeg -i - -strict experimental -c:a eac3 -b:a 224k “%f”

The codec & bitrate are not important as I’ve tried changing both with no luck both now & when this happened to me in the past.

In this case I just want to open an eac3 file in Audacity, edit it & then export it using the command above.

Any help would be greatly appreciated as I’m considering maybe splitting the audio in two, exporting both & then putting them back together & see if that works.

Additional info:

  • PC has 16Gb RAM.
  • Audacity temporary file directory is an SSD with ~90Gb free space.
  • Current space used by this project is ~10Gb so far.

Thanks again for any help with this as I don’t know what I’m doing wrong.


I cannot reproduce this on W10 with 3.3.2 and 2.4.2

I regularly use Audacity to record 2hours 15 mins of overnight webcast, trim it down to the two hours of the program and export it for later listening - always does and always has worked fine.


This topic was automatically closed after 30 days. New replies are no longer allowed.