Hi i have the latest version free of audacity and when i have a m-audio fast track USB box to record stuff. here is a picture of it: i have a problem with recording. I can record a first track and play it back and it will sound fine BUT ya know how when you start recording a second track it will play the first track that you recorded in a headset for you so that you know when to play in the second track? It sound really glitchy and all messed up. Like i can understand what I’m hearing but it just sounds really bad. BUT after the second track has been recorded and i just play the both of the tracks at the same time it sounds fine…
SO the real problem is that when i listen to the first track while i am recording the second one the first track being played in my headset sounds bad but when they are both just played (not during a recording) it sounds fine.

i have a sure sm58 microphone and i use a xlr cable to plug it into the box…if that helps

please tell me if any of this makes sense or its just my bad computer

please tell me if you have the same problem

please comment back!!! :smiley:


Numbers are good. “I’m using Audacity 1.2.6.”

It sounds like the computer can’t keep up. You’re asking it to play back, record, and time share manage at the same time. If there was going to be a stress point, this would be it.

If you have an older computer, it may be speaking one of the earlier USB connection types – one of the slower ones. If you’re on a PC, you can error check your hard drive and defragment it. Audacity will not work into a badly fragmented hard drive. It takes too long.


I have a similar/different problem. I am using Windows XP, a M-Audio Delta 44 card a USB Piano/Keyboard and Audio SFZ a sound foint player.

I can record the first track. When I record the second track. It is overdubbing the first track onto the recording of the second track. EQ: I can not play the second track solo without hearing the first track that is not part of the second track.
I have tried changing the overdub option and the playback option with the drop down preferences list, but I can not get track separation.


I have the same problem with the first track bleeding onto a new second track using Windows &. I didn’t notice it happening with the old XP os. I can’t seem to find a correction for it either. Anybody got a suggestion?

As none of you have said which version of Audacity you are using, I’d advise you all to update to Audacity 1.3.14 (Unicode) which you can get from here:

As you all have different problems, but all related to incorrectly or badly functioning sound systems on your computers, this article will probably a good place for you to start looking: