Linux Mint 17.3 : USB Turntable, can'tg force -6db

I’ve followed the guide here :

I have absolutely no problem while in Windows 7, but as I less and less boot in Windows 7, it would sometimes imply booting into Windows 7 only to rip a vinyl record so I can put it somewhere to share :sunglasses:

No matter what I do, reducing the sound in Pulse Audio…but that’s useless, didn’t work, and not surprisingly, as Audacity will only let me use ALSA, which is perfect ALSA> pulse and Audacious plays my music using ALSA not pulseaudio. But even after going into alsamixer…when I press F6 to change audio devices, if I pick the USB Audio Device which is the turntable it will tell me that it doesn’t have anything I change, I forgot the phrasing, but it’s basically, nope, no bars here.

Every record I play will go into the red zone, no matter what I do, in Windows it’s easy to tell the Recording device to keep it at a certain range. But finally after upgrading Kernel to a 4.x kernel, now the sound comes out when I play it from my turntable from my speakers.

There should be a simple option to just tell it to not record past -6db or some kind of line one could put on the playback bar (if that’s the wrong name, I mean the second bar, the one that I think catches what one plays when they press the Record button.

I’ve installed a bunch of plugins, well all of them, could it have something to do with it, not that I’m using many, but I’m about to use the Vinyl or such named plugin that makes whatever one records more vinyl-like…but I doubt I can change that.

By the way, lowering the sound in the Sound Preferences menu does nothing either in the Input menu, I can lower it completely and it won’t do a thing. Since 3 days now my hair is on fire, I got about 400 vinyls for free from my uncle who was into a lot of underground 80’s music, thrash, hardcore punk, indie rock, I got a trove and I can’t rip them correctly, at least now after the new kernel, I can have the sound come out my desktop’s stereo system, which is WAY better than the turntable’s. It’s not a bad turntable, but it’s the kind that can be fit into the “best kind for beginners”, cost me about 169 CAD. It’s not my dad’s Technics which he says he gives to me on his testament, but the guy is in shape other that the painkillers needed for his sciatica, these days 18 wheeler trucks barely have vibration inside the cabin and air pressure seats that feel like a massage, but when 20 years ago when I went around in rides with him (he’s a trucker if you didn’t get it by now) and my god those old MACKS trucks were a hazard if not buckled up). So yup, not about to get the 1984 grey Technics turntable.

That’s normal for USB devices. In fact, it is the same on Windows, though Windows hides the fact.

USB audio passes audio data only. There is no support for changing the input gain of the USB device.
Windows will (on some machines) allow the recording level to be adjusted, but this is done by scaling the digital audio data after it has entered the computer. In other words, it is identical to applying Audacity’s “Amplify” effect after recording. This does nothing to prevent clipping, because if clipping is going to occur, it will occur in the analog to digital converter (the A/D converter in the USB device) before being converted to digital.

To prevent clipping when the signal is too big, the analog signal must be reduced before it goes into the A/D converter. That can only be done by the USB device hardware.
Most full featured USB audio interfaces have rotary controls to set the analog input level. Unfortunately many USB turntables don’t, though some have an adjustment on the bottom of the turntable (turn the turntable upside down to access). Look in your turntable manual to see if your turntable has a level adjustment.

Well, now that makes sense, thanks.

But no, I don’t have any sort of button/meter. There is a Pitch sliding button that I just left in the middle, it only shows a difference in sound when at both extremes and I’m not sure what it’s for, it does change the sound, but I have a Tuning round turning button next to the Volume level one in case I would want to listen to records directly from it…it doesn’t play very loud by itself, but it sounds amazing with headphones I have to admit.

It has a composite red/white exit that I tried to use first with an adapter to plug in my not too shabby PCI-1x sound card but the sound would come out too low that time, since it’s not the kind with a phono plug, it’s not a surprise, there was a complete lack of bass too…I guess those are made so if you want to connect the turntable to a good sound system, I didn’t try in my living room, but I’m sure my Denon sound stereo would have it sound great. It even has in the back a black round 1/8mm like for the headphones. It says AUX IN, so I guess I can plug a walkman in there with my male-male cable like I used to do for albums I had that only existed in tape or vinyl and I had the tape, but I did all of those with my sound card a while ago.

Sigh, I’ll do a snappy recording session in win7 one timer or another then since it adjusts itself like you’ve said.

I’ve read your first post three times and I’m still not clear what problem you are having? Is the recording level too high? Too low? Something else? Does it sound distorted? What problem are we trying to fix?

You seemed to have understood what I said very well Steve when you first responded.

I even linked to the vinyl ripping guide. The sound as seen by Audacity cannot be maxed out at -6db, it’s bars full to the max in the red.

While in Windows 7, I can get the sound to come out at the correct (-6db) setting. Maybe sometimes it will go a bit over it and be yellow, but never full blown full bars deep in the red. There’s nothing I can do about it, lowering the sound from the turntable itself is useless, alsamixer and any attempts at making the sound coming from that usb jack lower doesn’t work. It’s pretty plain as day what the problem is about On the first page of the linked guide they mention that you have to have it this way or else, it’s all blocks of audio data if the recording is over 2db or even less than that. That was a strange response, your first one helped me understand what was going on and then you ask this question like if I posted in vietnamese.

Bottom of the line is that no, unfortunately the turntable doesn’t have a level adjustment. I don’t think the Pitch adjustment sliding thing does a thing either, so I’ll have to boot into Windows 7 to record the vinyls in Audacity. Thanks for your help in that first post.

Given that this is the case, why can’t you use your Linux machine?

I did it and yes the waves shortened, but still were blocks most of the time, but I noticed that say if there is a passage where it is just bass and drums and vocals and no electric guitar, the waves are not blocks then. They shouldn’t be blocks…I mean the EP that plays at 45RPM I try to rip was made in 1996, on a small indie label so I don’t think it’s a victim of the “Loudness War”. But what do I know, maybe it’s how it is and I should just use the Amplify tool once the recording is done.

Did it in Win7 with the latest drivers for my sound card and I can just reduce the recording volume straight up on Audacity, I made a very productive 4 rips (sigh), while I did that win7 installed so many updates, I hadn’t been on it in months, like march 2nd was the last time I booted up win7 x64 ultimate. Afterwards, it won’t boot, it gets to the “wait for updates to install do not turn off computer” and then it reboots itself, infinitely, even the Repair Your Computer Start Fixing isn’t repairing it, which is strange, it almost always succeeds, then I tried to go back to an older system restore point and nothing happened after 15 minutes of intense computing.

FUUUU…etc. You can see why I stick with Linux most of the time.

That’s on your Linux machine?

are you saying that with the same vinyl, the recording is not “blocky” when recorded on the Windows machine?