line sound is stopped when I start recording

Hi all,

I am using audacity 2.0.3 under Linux 3.3.8 (Gentoo). Up to now, everything has worked fine. My usage is recording teachings on streaming sites. In the audio mixer, playback and capture are mute for Micro, capture is on for line.

When I play the streaming on the web browser, I can ear the sound. Then when I start recording with audacity, the sound cannot be eared anymore, and the recording is flat. Then when I stop recording, the sound from the streaming can be eared again.

I have tried to reconfigure alsa with alsacfg and to reinstall audacity, without success. Any idea please ?

Do you have PulseAudio installed?
What settings do you have, and which of them are you using in the device toolbar?

Thanks for your answer steve,

PulseAudio is not installed, qjackctl is but not running (I use it sometimes for a midi keyboard).

In the device toolbar :

  • Microphone is on mono, defaut (other choices : Creative X-FI Front/Wave In (hw:0,0), sysdefault, default).
  • Speaker is on default (other choices : Creative X-FI Front/Wave In (hw:0,0), Creative X-FI surround (hw:0,1),Creative X-FI Center/LFE (hw:0,2),Creative X-FI Side (hw:0,3),Creative X-FI IEC958 Non Audio (hw:0,4), sysdefault, front, rear, center lfe, side, surround 40, surround 41, surround 50, surround 51, surround 71, iec958, spdif, default).

I have tried to run and start qjackctl and configure Audacity to use it and here, it works. This is only a workaround since 1) until now, it was useless for this purpose, 2) it is a bit complex to use for the rest of my little family.

In the absence of PulseAudio (and not using Jack) you are somewhat at the mercy of what your ALSA device driver supports. If you select the hw:0,0 option for both the recording input and playback output, then I think that you should be able to control the signal routing (as far as is supported by ALSA) using Alsa Mixer (to launch ALSA Mixer, type alsamixer in a terminal window). If that works, then there are various GUI front ends for ALSA Mixer - you may already have one installed.

I already tryed that, but with no result. Both on hw:0,0 or default (may be the same) leads to speaker and recording from microphone works, but if I select line instead of microphone and records, speaker is stopped during recording. Actually, it is like the sound is mutted, and it’s come back when I stop recording.

Can you get recording of streaming audio to work using arecord?

yes, with qarecord, it works, without the help of jack.

I’m not familiar with qarecord, but it looks like it has some fancy signal routing capability.
I’m trying to get an idea of what your sound system itself can do as a guide to how to configure Audacity. - can you record streaming audio with arecord, and if so, how?