limiting selected channels from usb-mixer

audacity 2.0.5
osx 10.9.4

is there a way to configure audacity, at startup, to “accept” only certain specified channels, via usb, from a multi-channel mixer?

my newly-acquired tascam us-16x08 seems to mindlessly send all 16 channels to audacity. i only use four (1,2,9 & 10 – mostly because those jacks are on the front panel). when the record button is clicked, all 16 channels show up, only four of which have anything interesting on them. i’ve “moved up” channels 9 & 10 and x’d out the unwanted channels, but after i start and stop the record phase (necessary, evidently, to get the tracks to appear), a restart leaves the four tracks i’ve selected and instead adds, below them, 16 more tracks and begins recording all 16. i didn’t have this problem with my previous gear because it could ONLY send four channels. tech support at tascam tells me that the 16x08 sends all the channels “like other multi-channel mixers” and that it is up to the daw to make the selections.

i’ve dedicated lots of time to this issue – even bought carla schroder’s book – but haven’t been able to find documentation which addresses this issue. i hope it’s in the cloud and you can just point me to it. i just know i can’t be the first to be baffled by this problem.

thanks for any help. jim.

This sounds an awful lot like something you would do in Utilities > Audio MIDI setup. I think it’s job is to manage details like that. Attached.

Screen Shot 2015-09-29 at 21.28.04.png

Would muting channels in Audio MIDI Setup prevent Audacity creating tracks for them? I would doubt that.

Audacity cannot yet pick and choose non-contiguous channels to record or allocate specific channels to specific recording tracks. It’s a long-standing “feature request”. The best you are likely to be able to do is set Audacity in Device Toolbar (rightmost box) to record 10 channels.

Let us know if that works for you.


Install the included Tascam software. That allows you to route any channel to any channel.

Additionally, you could limit the number of channels in Audio/Midi setup, I think. It’s not supported by every interface and I’ve never tried it with a Tascam.

thank you all for putting me on the right (and, unfortunately) only track. i’ve had time to try these ideas out and they work. it is going to be cumbersome. nothing worth doing is easy. thanks, again. jim.

Is that usually done by “muting” channels in Audio MIDI Setup, or do devices that support it add some other control into Audio MIDI Setup?


USB class audio devices usually have no controls, although it is possible. I’ve just never seen one. But there’s only provision for enabling and gain in USB audio class. No phantom power, fi.

Interfaces with more than 6 channels usually come with a driver and/or setup application because these usually contain gain settings, phantom power switches and routing or even dsp’s.

In Audio Midi setup, these controls are only available when the driver exposes them. If not, they’re greyed out. What you see is what you get, there are no additional controls. Only gain and “enable”. Most drivers don’t need Audio Midi setup, so they don’t expose anything to AM setup.

So the answer is: YMMV according to the driver and the interface.

Sometimes, you can switch back from 8 to 4 to 2 channels. Sometimes only from 8 to 2. Presumably, that’s to avoid trouble with software that can’t cope with more than 2 channels. Sometimes, you can only disable channels in pairs, sometimes individually.

OK but Audio MIDI Setup does not show “Enable” for stereo devices (that I can find). Each channel has a “Mute” button. In the absence of a control panel supplied by the device manufacturer, is muting a channel in Audio MIDI Setup what the user would try to stop the device sending that channel at all?

Or would such a control be exposed behind a configure button?

I’m just trying to figure out where we would suggest a user looks in Audio MIDI Setup.


What you see is what you get…

I mean, if the control is available, MA setup will show it.

And mine’s set to Dutch. It’s probably “mute” in English, which is a bit misleading, as it effectively disables the channel and it shouldn’t show up in Audacity.

Usually you don’t have to fiddle with channel enabling in AM setup. Here’s a picture:

It’s an older version, with inputs and outputs side-by-side. These days, inputs and outputs have their own panes.

There are mute and playthrough settings, besides gain. In this case, on the input side, there’s only a master gain and you can’t mute channels.

On the output side, there’s only a mute all, but levels can be controlled on a channel-by-channel base. Of course, there’s no playthrough on output…

PS/OT/BTW. Audacity isn’t the only one using “32 bit” as a source format where it’s wrong, imho. I just noticed AM setup does to. It shows my RME as 8 channel, 32 bits. :unamused:

Now I’m confused. Again. :confused:

Presumably that is for any processing that Apple do? Oversimplified, Windows Vista and later do internal audio processing in 32-bit float, if not turned off by using “Exclusive” mode.


I suppose so, Gale.

I think Core Audio is even 64 bits internally? But don’t quote me on that. I used to be more familiar with CA. That grinded to a halt when Apple decided their devs could no longer participate in the CA dev mailinglist. That policy has been abolished since, I hear, but meanwhile the list died for me.