Limiter issue? Recorded files being capped?

Hello, does anyone know why my sound files being recorded are now capped and the waves not showing in full? This has happened before and I can’t remember what I did to rectify it? All I did was alter the recording volume top left a little, now my files aren’t showing in full and have a flat top??

Sounds similar to this …

Thank you, no it’s not that. It’s so strange as I know it’s something simple but for the life of me I can’t get it back to normal!!

Perhaps we may be able to help if you give some details about your setup and what you are doing.

Almost certainly that is the result of “clipping”.
“Clipping” occurs when an input signal exceeds the maximum available amplitude. For example it can occur when over-driving a microphone or amplifier. It can also occur in the digital domain by exceeding 0 dB anywhere in the signal chain. It can also occur as a result of poorly written device drivers incorrectly mixing or splitting audio channels.

Yes i’ve looked into all the clipping settings and can’t find a solution, all i’m really using it for is recording my vinyl to mp3, and dj mixes to mp3, straight from my mixer, into the pc and audacity.

Does the recording sound distorted?

Are you able to monitor directly from the mixer? If so, does that sound distorted?

How is the mixer connected to the computer? If it’s a USB mixer, what’s the make / model? If it’s not a USB mixer, what is the make / model of the sound card / audio interface that you are using?

Are you recording in mono or stereo?

Please post a short audio sample to demonstrate the problem. Just a few seconds in WAV format (see:
(WAV format is important as some important clues about the problem can be hidden by lossy encoding).

Recording is stereo. The audio is fine, that’s not the issue. The issue is visually as now i’m seeing my files with a flat top and can’t fully gauge when recording in, if i’m going to high to distort it. Hope this makes sense. I need to know how to stop it capping the files, they seem to still record ok, but they are all showing a flat top instead of the full wave.

No matter where I put the recording level too on Audacity, it still records with a flat top on the recorded file wave??

How do I post up a sample? Sorry! Got one here…

Details here:


You forgot to answer some questions about what hardware you’re using and how everything is connected…

Trying to upload a file but I can’t see this??

“Look below the message composing box and click on the “Upload attachment” tab.”??

Failing at every hurdle here. haha.

Try again now.

was there a solution? I am experiencing same issue.

Clipping can occur anywhere within the signal chain. For example, some 12" singles are recorded so loud that they can overload normal consumer record players. Once the audio is clipped, the clipped signal will continue through to the analog/digital converter, into the computer, through the computer sound system, into Audacity and written to disk. To solve clipping problems, you need to trace the signal path from the sound source and check that at each step it does not clip.

I’m sorry. I believe the issue is with a setting in Audacity. I’m getting clipping on version 2.3.2 on Windows 10 laptop. When using old Vista desktop with version 2.0.2, I am not getting clipping.

Pleas tell us about your hardware setup.

I’m sorry. I believe the issue is with a setting in Audacity

Audacity doesn’t mess-with the digital audio stream like that. It simply “captures” the digital audio from Windows. But, there are a couple of Windows settings that can mess-up the sound before it’s recorded.

yes, I understand its most likely a Windows issue. I’m not sure what you need for hardware. I’m using Toshiba Satellite laptop, intel i7-26700QM, 6GB ram, Windows 10 ‘Home’ build 19041.685, 64 bit os

I’m not sure what you need for hardware.

What are you recording? Are you recording from an analog microphone plugged into your computer? A USB microphone? A USB turntable, etc.?

Or are you recording streaming audio with no additional hardware?