Hello everyone ! I have a problem with the latency on audacity 2.06.while i’m singing , my voice comes out from the speakers late,but if sing without listening my voice there isn’t any can I do ? I wanted to install the drivers asio but they do not work with audacity
my notebook:
windows 7 64 bit
my integrated sound card:
idt high definition audio
my mixer
behringer q502 usb
audacity version 2.06.exe
thank you!

Firstly, assuming that you are recording your singing, you should not be listening through speakers. Doing so causes all sorts of problems in the recording - use headphones.

With your computer switched off, plug your headphones into the q502, and also plug your mic into the mixer. If necessary refer to the Behringer manual and set the mixer so that you can hear yourself through the headphones. If it is not possible to do that, then you will need to make do with hearing your own voice acoustically.

When you’ve got that sorted out, switch on your computer.
Get Audacity up and running and check that “Software Playthrough” (in the “Transport” menu) is OFF (not selected) and check that “Overdub” is ON (selected).
In the device toolbar, set the USB mixer as the recording and playback device.

Are you using MP3 backing tracks? If so, import a track into Audacity (File menu > Import > Audio) and adjust the playback levels so that you can hear it through your headphones.

Set your recording levels, starting from “Gain” control on the mixer, then the Level and Main Mix controls on the mixer, then finally the recording levels on your computer (for USB devices you often have to go into the Windows Sound Control Panel to to that).

You should then be ready to make a test recording.

This tutorial may be helpful:

Whatever you’re using as the first, rhythm, or reference track has to play back from Audacity. Audacity has to manage both the live microphone recording and the playback track.

Listening to live speakers seems to be a good idea until you find Audacity recording the wrong things onto your voice tracks—and you can’t stop it.

Headphones are good.


my mixer is already set to listen through headphones.
there is latency with headphones and also with speakers.i sing with the right time and when I listen to the result it’s good.delay is only while i’m sing hearing my voice in delay is annoying .to hear my voice on the headphones I set the choice with the microphone settings on win7.
I clicked the voice “listen” on “recording settings” and chose “listen the microphone through headphones” .mixer settings give a different result ?Software Playthrough" is off “Overdub” is on.i’m using MP3 backing sound control panel is ok.input device is with my mixer('cause the microphone is there)and also output is with my mixer 'cause the headphones are there.

Got to Edit → Preferences → Recording and try reducing the latency. If the buffer size is too small (and associated latency too low), you’ll get glitches. But, it’s worth trying to see how low you can go.

Ideally, you’d monitor directly through the mixer/interface (without the latency through the computer). But with your mixer, I don’t know if it’s possible to record with USB and listen to the backing-track coming-in via USB while also directly monitoring the analog mic input…

I’m pretty sure you can get zero-latency monitoring if you use the mixer as an analog mixer (with no digital connection to the computer) but something “different” may happen when you use the USB port. I don’t know… Is there a Behringer user forum?

There might be a way to use a 2nd USB interface (such as the Behringer UCA202) along with the mixer. The idea would be to use the mixer as a (analog) mic preamp and (analog) monitoring station while using the other interface for recording. You could use one of the mixer’s analog inputs for the backing-track.

[u]Here’s an example[/u] of an interface with direct zero-latency hardware-monitoring.

An interface doesn’t have all of the features of a mixer. It’s assumed that mixing, panning, EQ, etc. will be done in software (and usually in post-production). Also, a multi-input interface can record multi-track, whereas your 5-input mixer can only record the 2-channel stereo mix. (That’s not an issue for you right now, but it’s something you might want to know.)

to sing hearing my voice in delay is annoying

That one is computer latency. I’m surprised that you have that delay when you are listening to the mixer. That delay normally happens when you listen to the computer. If you disconnect the computer or turn it off, can you hear yourself OK at the mixer?


the buffer size is 0 and latency is -130.when I installed audacity latency was already set to -130.sorry can you re-explain this part of your reply? “Ideally, you’d monitor directly through the mixer/interface (without the latency through the computer). But with your mixer, I don’t know if it’s possible to record with USB and listen to the backing-track coming-in via USB while also directly monitoring the analog mic input”
sorry , but I’m not very experienced…
@koz can the mixer also work without connecting to PC USB to hear if there is latency ?

Overdubbing makes your head hurt because you have to manage sound going two different directions at once.

What’s supposed to happen is you listen to your mixer and hear your own voice perfectly in real time. That’s sometimes called “Zero Latency Monitoring.” No echoes and no delay. The mixer, if it was made to do so, mixes the rhythm or guide track playing back in Audacity so you can match your voice to it in rhythm and pitch. At no time does Audacity or any other program send your live voice back to you. That’s the kind of thing that causes delays and echoes.

At the same time all that’s happening, the mixer sends your voice to Audacity so it can create a fresh, new track with just your voice on it.

When you get to the end and play it back, you will have the original rhythm track and your voice on its own track playing at the same time.

Two settings can mess this up: If you leave “Playthrough” selected in Audacity preferences, Audacity will try to send your voice back to you late. You can also get that kind of thing if you told Audacity to record Stereo Mix and not your mixer. Set that using the Audacity Device Toolbar.

If you’re hearing your own voice delayed, chances are terrific at least one of those settings is wrong.


is it possible that I should change from mono to stereo ? I’ve never understood the difference , I just saw that if I change in stereo when I’m recording the voice audacity creates two channels
do you think that latency settings that I wrote before are ok ?

latency settings that I wrote before are ok ?

Those are Recording Latency settings. Not Machine Latency. They don’t affect listening to your live voice. We can set that later.

Audacity > Edit > Preferences > Recording: [X] Overdub and no other settings checked.
Audacity > Edit > Preferences > Devices > Recording. This should be set for your mixer.
Audacity > Edit > Preferences > Devices > Playback. This should be set for your mixer, too.

I would have said to use Mono, but some stereo mixers don’t work right if you cross stereo and mono data connections, so use Stereo.

Here’s a test. Set up for an overdub like you have been doing it. Press record. Yes, your red Audacity sound meters jump in time to your voice. Do the green ones jump, too?


Now this has happened : the music comes lightly first and then I sing slightly before.This happens unless I hear my voice on the headset

I have solved the problem .

if you want I’ve found audacity with drivers asio

Well, the person who is distributing that is contravening our licence or that of Steinberg, so please keep it to yourself for your own use, and we can’t give you help with that version here.