latency when overdubbing

I can’t adjust or control the latency when I’m recording a 2nd or third track. I tried to follow directions from the help section, but it’s still a little off.
I am using a mixer and my laptop. Audacity 2.0.6. Windows 7

There are two latencies: Recording latency where you use the Audacity tools to make your new track match all the older ones. Then there’s computer latency where you try and listen to your live voice and it’s always late. Which one do you have?

this will help! :slight_smile:

Correct me, but didn’t he just match up the trailing edge of one track with the leading edge of the other? Is this one of those fixes that only works with his computer?

Wouldn’t you want to match up the two leading edges?


Which still may not be the right latency. The poster needs to tell us.

It’s also odd that YouTube comments have been turned off.