Latency set up works only partialy, and piercing whistle

Hi everyone,

I’m experiencing strange troubles with audacity and my audio interface. I wonder if I could find any help here.

I have been setting up the latency this afternoon with this method ( on a focusrite 2ia. Last time it worked great but I made a couple of changes on my computer so I had to do it again.

At first It worked beautifuly the two rhythm tracks were on sync, then I tried to play a couple of guitar tracks and all of the sudden the overdub was moved to much on the left.

They I tried again with the rhythm track… It worked. And suddently it stoped working, the overdub was to much on the left again.

So I figured I’ll do the method once again. But suddendly when I approached the mic close to the amp to record the clic, it started doing a piercing whistle.

The strange thing is it’s doing it only when I plug my amp on the first output and input of my interface.

Anybody would know where that comes from ?

Thanks in advance :slight_smile:

Check the settings in the device toolbar. The recording input should be set to the microphone, not “stereo mix”, or “sound mapper” or “loopback”.

Also check in the Windows Sound Control Panel that “listen to this device” is not selected for the microphone input.

Also check that “Software Playthrough” is not enabled (Audacity “Transport” menu).

Ok thanks ! it worked great !

I have 2 other questions though :slight_smile:

After installing Audacity 2.2.2, I’m getting this message : (see the attachment) it doesn’t harm the recording apparently but it is weird. Do you know what it could be ?

Finally, when I record in mono (using my focusrite 2i4) it records only my input one. I have to use stereo mode in Audacity to have the input 2 being recorded. Is it a normal thing ?

Thanks for the help ^^
Problème desinstallation.PNG