Latency Problems

Hello. I am using audacity to record myself playing guitar, but ever since I updated to 2.0.5 I’ve had an issue with the latency. I use the overdub feature to record over a backing track, but when I play back both tracks my guitar is slightly lagging behind the backing track. At first I just thought I needed to adjust the latency correction in the preferences, so I did and that fixed the problem… for one recording session. As soon as I did a second recording the problem was back, this time with a different interval of error (ex. the first time it was behind by .020sec, the second time it was off by .045sec).

After a little experimentation I found that every time I press the record button and dub over a different track the two tracks are off by a random number of milliseconds each time. I cant correct for it with the latency correction in the preferences because every time I hit record it is screwed up again. I tested this with my guitar and by generating a click track and playing that through the speakers while my microphone recorded it and found the same result in both instances.

Is there a fix for this issue that anyone knows of? Any help would be greatly appreciated, it’s driving me crazy.

The cause may be simpler than you think. The computer may change speeds if it’s beginning to run out of resources. Are you filling up your hard drive? That’s the first place to look. Defrag your brains out (assuming older than WinVista) and make sure you have at least 10% to 15% of the drive free. Close everything or restart the machine and then don’t run anything else except Audacity while you’re doing production.

What the latency adjustment is doing is compensating for the finite time the machine takes to put stuff on and take stuff from the drive. On a machine with plenty of resources, this number stays pretty constant, but on a machine that’s lagging or huffing and puffing, it can wander.

Is there any other reason your machine could be changing its efficiency or speed over time? Is it XP and have you ever defragged it?


You know 2/100 of a second is not a terrible wander. Computers are not Digital Audio Workstations. I bet you can’t hear that. I also bet no rock band in history has ever started up with that kind of accuracy.


Sorry for the late reply (you know how the holidays are) and thanks for the input as well. I dont think the problem is storage space on the hard drive as I have more than 75% free space, and the defragger is indicating that the the disk doesnt need to be defragged. I do wonder, though, if I was just running too many programs while trying to record that were chewing up too much of the processor. I didn’t think that I was running that many, but my machine is getting kind of old and slow. In response to your question I am running Windows 7.

Now for the kicker, the problem seems to have gone away for reasons I cant discern. I played with the settings a little bit more, but I didnt really do anything I hadn’t already done. I am anticipating that it will be back, though that could just be my skepticism. If you have any other ideas about what might be causing this I’d love to hear them in case the problem returns. Thanks for your help so far.

Obviously use as few other programs as possible. If you are running a complex security suite that is constantly running behaviour checks and scanning files, or some other resource intensive program that is always doing something, this could make latency variability worse.

If you always sleep or hibernate the machine overnight, consider shutting down the computer completely and restarting it.

What host are you choosing in Device Toolbar ? MME is likely to have least latency variability, though it may have the greatest latency.


If you always sleep or hibernate the machine overnight, consider shutting down the computer completely and restarting it.

I think you may have solved it right there. When I was having this issue it had been a while since I had shut it down. At least that may have been a contributing factor. To answer your question, I am using MME, yes. But in any case, the problem seems to have resolved. If, in the future, it shows up again I’ll be sure to hit you guys up again. You’ve been super helpful and I appreciate it. Love the program too. This is really only the first problem I’ve ever had with it after years of using it. Thanks so much for the help.