Latency issues on Windows Vista

Hi I use an Audio Technica Microphone that directly plugs into my computer via USB. The headphone jack is located on the Mic itself. When I try to record the latency is so delayed it makes it impossible to record. I’ve tried changing only having Overdub checked in the preferences but then when I attempt to the record the needle seems stuck and no tracks will play or record. Does anyone else have a similar issue? I really could use the help. Thanks!

The headphone jack is located on the Mic itself.

What mic do you have? Usually when there’s a built-in mic jack there’s a way to monitor yourself directly (not through the computer). Check the the user manual for your mic.

If you can do that, turn off [u]Software Playthrough[/u].

The microphone has to list “Zero Latency Monitoring” as part of its talents. If everything is working, you should be able to hear your own voice with Audacity stopped.

The G-Track microphone has a separate volume control for the headphone service.

…and the UCA-202 has a switch you have to throw to turn on local monitoring.
Screen Shot 2018-02-19 at 10.54.30.png
Everybody does it a little different, but no, you can’t get your own voice from Audacity. That will have a terrific delay and echo.

Which microphone exactly?