latency in headphones while recording

Hi,

I’m trying to record my vocals over a song, but am hearing my voice half a second behind me, making it hard to sing. I’ve lowered the buffer and used maestro’s low-latency mixer for my apogee duet (https://www.youtube.com/watch?v=fo7SwxvEwOs) but still have problems. any suggestions? I’m operating on a max 10.9.5 and Audacity 2.0.6 thank you!

Katie

am hearing my voice half a second behind me

Yes. That’s correct. That’s machine latency. The time it takes for your voice to get into the computer “normally,” turn around and come back out again. I illustrated three different ways to stop that by listening to the recording hardware instead of the computer. The hardware performs the zero latency mix.

Audacity > Preferences> Recording. Playthrough should NOT be selected on that panel. That’s guaranteed to be off time.

The Low latency Mixer must get your live voice from the computer, USB connection or Duet Device, not Audacity. Did that Audacity setting help?

Koz