Latency Error recording WASAPI computer playback[SOLVED]

I’ve been using Audacity for about a year and a half with no problems until this evening. The first problem was in loss of input volume. I was not even getting a wave pattern at all when I tried to record. While in the midst of grappling with that problem, suddenly I could no longer record at all. The cursor would just pulse at “zero” and I would get a Latency correction error. The error message prompts you to either used the Time Shift key or F5 on the keyboard to drag the track where it would be visible. I clicked on the Time Shift button, tried to used my cursor to slide the bar at zero to some other place and nothing. Also tried using F5 and my mouse to attempt to drag the marker off zero. No luck at all. Sorry if this has been answered or discussed. I have looked in FAQ and in Troubleshooting Recording Issues and haven’t gotten any solutions.

As you have discovered, that will not help.
That error was triggered because the recording failed after perhaps recording a tiny fraction of a second. Of course that is not an expected thing to occur, and consequently the error message is not helpful (I’ve raised this issue with the development team to see if it can be improved).

The important part for you is why the recording failed.
Are you using the built-in sound card in your computer or do you have some other recording device?
What were you trying to record?
Have you tried rebooting the computer? If not, try that first.

If the problem persists, please tell us:
Which version of Windows.
Which version of Audacity (look in “Help > About Audacity”)
What settings are available in the device toolbar and which settings are selected.

Thanks for the help!

  1. I am using my computers built-in sound card.
  2. I was recording something off YouTube when this error occurred, but I was not just recording, I was attempting to correct a problem I was having with inadequate volume. That was causing me to start and stop the recording repeatedly after letting it record only long enough to determine whether any of the changes to the volume settings had corrected the problem I was having with volume. I tried rebooting the computer. I tried uninstalling and re-installing Audacity. I tried going to YouTube and looking for videos about correcting this error and Googled it and found nothing useful.
  3. I’m using Windows 7 and Audacity 2.0.5.
  4. In the Device Toolbar, my settings are Windows WASAP, Speakers Realtek High Definition, Realtek Digital Output and Stereo Input.

Hope you can help me resolve this, cause it’s driving me nuts.

Those settings probably won’t work because under WASAPI host, the third input device should be the (loopback) input for the same playback device that’s specified in the second box.

So try “Speakers Realtek High Definition (loopback)” for the input device.

The input volume level under WASAPI is fixed for most devices, and the input level slider in Audacity will be greyed out. To get a good input level you need to turn up the output level of the program making the sound (the browser flash player in your case) in Windows Volume Mixer. To open the Mixer, left-click the speaker icon by the system clock, then click “Mixer”.

Under WASAPI, you will often need to start playing the stream before pressing Record in Audacity, especially if you just started Audacity.

Open the Transport Menu in Audacity, and make sure Sound Activated Recording is not ticked (not checked). If it is checked, click it to uncheck it.


Gale

Hey, I changed the settings as you suggested and I’m up and running again. Really appreciate your help! I have been very pleased with Audacity, unfortuantely I am not as tech-oriented as I should be to be able to figure things out like this. Thanks a ton!