Latency correction not working

I’m using Audacity version 2.3.3 and Mac OS Catalina, version 10.15.3
II have gone through the steps outlined in the user manual for adjusting the latency and have entered the amount in the Latency Compensation box under Preferences>Devices. But when I check the results, the lag between the original recording and the looped back recording hasn’t changed. There are no arrows at the left end of the recorded track to show the latency correction has been applied even though the Latency Compensation box still shows the amount I entered (in my case -.480).

I’ve had to adjust the latency in previous versions of Audacity and it has worked before, so not sure what’s changed.

Audacity no longer records before time=0, which is why you don’t see the “<-” arrows.
Use these instructions for latency correction:

Sorry, I’m not following. The instructions in the link you provided are the ones I followed. The instructions tell you to enter a negative value in the Latency Compensation box, which you’re saying doesn’t work in the current version of Audacity because it no longer records before 0. So there’s no way to correct for latency?


No, I’m not saying that. I’m saying that the instructions work.
The only difference now is that the bit of the track that was previously written before time=0 is no longer written to the track.

If you set the latency correction to -100 ms, then the first 100 ms of samples that pass through the recording buffer are discarded.
If you use a click track, as described in the instructions, then the aim is to get the clicks in the second track to line up as closely as possible with the clicks in the first track.

Thanks, appreciate your help but the latency correction isn’t working for me. After entering -.480 in the Latency Compensation box and re-doing the loop back recording, the second track still doesn’t align with the original click track. There’s a marginal difference of .017 between the first recording and the results test i.e., the ‘gap’ changes from .480 to .463. Any suggestions of what else I might try?

Is that your actual figure? “-0.480”?
The time is in milliseconds. A typical value is -100

Yes, I’ve done the process quite a few times now and the value is always between .461 and .480. I’ve attached a screenshot (I think)
Screen Shot 2020-03-19 at 7.18.52 PM.png

If the correction entry is in milliseconds, then the correction should be 461. The illustration is 0.461 Seconds. That 461 milliseconds.


There is a relatively easy trick to set this if you’re goal is to record a live microphone in overdubbing. Record the headphones. Make a click track be the backing track.

If you’re not using headphones for overdubbing, it’s going to be a long night.


Got it. Thank you for your help, and your patience.

When I change my latency parameter in preferences nothing happens. I went through the steps to correct but nothing changes, any ideas? I changed from -130 to -121 and nothing, I put it at 800 and nothing. I made sure that my test was on the money, after all of that I still get a delay sounding like a quick slap echo with no repeat.

Any ideas?

sounding like a quick slap echo with no repeat.

Latency compensation helps to synchronize your recording with a backing track when they are mixed later. I doesn’t do anything to the real-time monitoring.

Any ideas on being able to monitor as you play along with a track? I can’t do the overdub if I can’t hear the tracks. When I click on monitor the track or start to records I get that delay and as you know it’s impossible to play along.

Appreciate any thoughts or ideas,

There’s two overdubs. Regular overdubbing you sing to your backing rack and Audacity produces a new voice track underneath your backing track. You don’t hear yourself or the mix until you play it all back later.

Then there’s Perfect Overdubbing where you hear a theatrical mix of both you and the backing track in your headphones during the recording. That one’s harder. You can’t listen to the computer for that. You have to listen to your microphone, mixer, or interface—and whichever one you pick has to support overdubbing. Not all do.

Screen Shot 2021-12-20 at 1.38.50 PM.png
Even if you do hear yourself by plugging the headphones into the computer, your voice is always going to have an echo. The latency setting is for matching up your tracks when you listen later.


The Recording settings can cause problems.

Audacity > Preferences > Recording.

Screen Shot 2021-12-20 at 4.10.50 PM.png
Playthrough can cause your voice to come back whether you want it to or not—and it is going to be late. Turn it off.