I’m using audacity for about 5 months. I use Windows 7 and, as interface, my digitech rp 500 multi-effects guitar pedal, and it was perfectly working, but, now, when I try to record my guitar, audacity shows the message:

“Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift to drag the track to the right place.”

I have already uninstalled and reinstalled the audacity many times, without success.


Are you reinstalling Audacity 2.0.3? During the installations, did Audacity ask you if you wanted to completely blow away the old installation, or keep the preferences? Audacity default is to keep your old operating environment and so “reinstalling” usually doesn’t do a thing.

But I think this “before zero” problem has nothing to do with the install. I’ll need to let one of the Windows elves take it from here.


This isn’t Windows-specific. The recording is stalling, and because you have Transport > Overdub on, Audacity’s mechanism of pushing an overdubbed recording backwards to keep it synchronised is pushing it behind zero on the Timeline.

If the blue Pause button became depressed when you recorded, this means you turned Transport > Sound Activated Recording on, but your recording is not loud enough to start the recording. Click on that menu item to turn Sound Activated Recording off.

if the recording still stalls, you will need to find out why. Maybe you set the project rate bottom left too high or set “Audio to Buffer” too low in the Audacity Recording Preferences. Or maybe you need to restart the computer to replenish resources.

Also make sure you connect the interface to a spare USB port, not to a USB hub that has other USB devices connected to it.