LAME problem with Audacity 2.0.2 on Windows 7 (64 bit)

Whenever I try and export an MP3 and it asks me to browse for the location of the LAME dll, I get this error message:

You are linking to lame_enc.dll v3.99. This version is not
compatible with Audacity 2.0.2
Please download the latest version of the LAME MP3 library

follwoed by:

Could not MP3 encoding library!

I have both lame_enc.dll and lame.exe in the main audacity folder. C:Program Files (x86)Audacity

The version of lame that I have is lame3.99.5 which is the latest version I thought. So I don’t know why it won’t work. I tried using both the 64 bit and 32 bit versions of LAME to no avail.

Try removing your current version of Lame, then re-install Lame by precisely following these instructions: http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#lame

I followed these exact instructions. I removed the two lines from audacity.cfg and I deleted the lame files and reinstalled them. The error message though was the same.

I also upgraded to Audacity 2.0.4 and that didn’t fix it either.

I followed the directions again and got it to work this time! I’ll tell you what I did differently this time.

The first time: In the instructions above I was told to download Lame v3.99.3 for Windows.exe. But every time I attempted to download this file I got an error message. So I was using a different version 3.99.5 that doesn’t self install. That version should have worked though.

The second time: I made sure that my browser was sending the referrer header when I downloaded the file. Voila the download worked. Apparently when you have referrers disabled (how I usually surf) it doesn’t send the referrer header and the download doesn’t work. It just says 403 Forbidden so I had no idea it was something I was doing the first time around. It would be better to have a notice about referrer headers there.

Anyway it’s working now-- so thanks!

It is better to use the “recommended” 3.99.3, because most arbitrary versions of lame_enc.dll downloaded from the web won’t work in Audacity.

If you want 3.99.5 then at your own risk, you can try this libmp3lame.dll: RareWares - LAME Libraries. Change the file filter when you browse for the file in Audacity, or rename the file to lame_enc.dll.

We don’t control http://lame1.buanzo.com.ar/ or the security policies on that site. Please contact the site owner.

By the way Audacity 2.0.2 is obsolete. There should be a new 2.0.5 version in a few days’ time.


Gale