Label Track Management bugs

I’ve been having two issues with managing Label Tracks, ever since v. 2.4.2 I searched the forums, but could not find this specific issue. I’ve tried different search criteria, but perhaps I’m missing something.

Grabbing the circle handles of a label used to slide the entire label, it no longer does that. Instead, it behaves just like the chevron handle, adjusting one side or the other only. If I use Shift, then the circle handle works. is this how it is intended?

There is an issue, sometimes, when I try to create a new label. When I click in the label track, suddenly the entire sound track is selected and the tool is changed to the Envelope tool (?!) I have to de-select the tool, and try to create the label several times. This is intermittent.

As i said, I have tried to Search these items. I apologize if this is documented in the Forum.

Thank You,

Ron

Yes, that’s as intended.
The behaviour was changed to accommodate additional functionality. Label Tracks - Audacity Manual


Sorry, I’ve no idea about that one. I’ve never seen that happen.

(Normally I select the Envelope Tool by pressing the “F2” key, and switch back to the normal Selection Tool by pressing “F1” key.)