Just flatlines while trying to record a song playing on com

I have set the toolbar to the following, MME and stereo mix (high tech real def), however, when hit the record button all I get is a flat line with nothing being recorded. The song I’m playing, and would like to record is playing on the computer. I can hear that fine thru’ the speakers. Any suggestions? thx Monk

There’s some tricks to this and there’s more than one way to do it.



Assuming that you are using Windows Vista or later, try using the “WASAPI loopback” method described on the page that Koz linked to (that method tends to be the most reliable, but is not available on Windows XP).

Thanks Koz/Steve: the stereo mix option didn’t seem to work, however the Wasapi option worked. there still seems to be a prob, the recording bar doesn’t move past zero and when I hit stop I get a message regarding latency problem. any idea how to overcome that? thx Monk

Turn off Transport > Overdub and turn off Transport > Sound Activated Recording so they do not have a tick (checkmark) by them.

Then try playing the song before you press Record. Device Toolbar should look something like this:


Gale, thank you so much …

Can we mark it SOLVED?


Strange, it worked for a while but then reverted back to the latency problem. I’ve unchecked everything in transport, my settings are Wasapi, speaker(loopback) etc… but still the line does not move beyond 0… any thoughts? Monk

The “etc” does not tell us what the playback device and channels are. Try Speakers for playback device and stereo channels. Use 44100 Hz project rate bottom left.

Play the song before you press Record.

Also where is the song playing exactly? If it is a file on your computer, import the file by dragging it into Audacity. If it is an M4A or WMA file, Audacity can import it if you add FFmpeg to your computer.