Jesusonic (JSFX) plugins introduce delay

when running JSFX plugins with the latest reaJS VST, the JSFX plugin will sometimes introduce a delay (depending on whether the output is delayed at all). This happens even when pdc_delay is set to an appropriate value. Expected behavior is that the delay passed to pdc_delay should be compensated for in audacity like it is in reaper, if at all possible. Is it possible to compensate for that delay? Is there perhaps a different way of coding the JSFX so that the delay can be compensated for by audacity?

Have you tried playing with the “Options”?

  1. Open the effect
  2. Click the “Manage” button (the “Hamburger”)
  3. Select “Options”

I’ve tried Latency compnsation, but it does make any difference, setting the buffer size high or low does not appear to make any difference.

I know how much delay it is going to introduce, perhaps if there was a way to manually compensate for it. (Preferably from the plugin interface, perhaps in those options, rather than having to introduce that many samples of silence at the end then after running the effect removing them from the start)

The plugin that I am using does have PDC (Plugin Delay Compensation) enabled, but either Audacity is not aware of that, or is not using it. I’ve also tried disabling “Latency compensation” in audacity, but that makes no difference.

You could create a Macro to cut the first bit from the start of the selection, paste it to the end of the selection (and optionally silence the pasted part if it contains noise rather than silence). You can then create a keyboard shortcut to activate the Macro (https://manual.audacityteam.org/man/keyboard_preferences.html)


For example, to trim 0.1 seconds from the start, paste it to the end and silence it:

Fullscreen000.png