Jackd not working in 3.0.2

Where can I download a version of 2.4.2 (for 64bit linux)? In that 2.4.2 version I could select the jackd interface, whereas I cannot in the 3.0.2 version (upgraded this morning).

If the jackd service was running, then I always had the option in 2.4.2 interfaces to select alsa or jackd and if jackd was not then I only had the option of alsa. In 3.0.2 it only presents alsa whether jackd is running or not.

Although I would love to go forward and find a solution for the 3.0.2 jackd failure, I would rather just have audacity working and see if it is fixed later.


To date we have only every released source code for Linux.
The Audacity 2.4.2 source code is available here: https://www.fosshub.com/Audacity-old.html
or directly from GitHub: https://github.com/audacity/audacity/releases

I’m using Audacity 3.0.2 built from the source code on Xubuntu 20.04 and it works fine with Jack (see image below).
If you updated Audacity through the package manager, it may be worth reporting the problem to Mint.


Just a thought - You should normally start Jack before launching Audacity. Did you do that?

Yes, Jack is always started before Audacity, otherwise the Jack interface would not appear in the interface host list.

Jack is actually automagically stared via SuperCollider, here is the SuperCollider post data…

JackDriver: client name is 'SuperCollider'
SC_AudioDriver: sample rate = 44100.000000, driver's block size = 1024
JackDriver: connected  system:capture_1 to SuperCollider:in_1
JackDriver: connected  system:capture_2 to SuperCollider:in_2
JackDriver: connected  SuperCollider:out_1 to system:playback_1
JackDriver: connected  SuperCollider:out_2 to system:playback_2

This is showing exactly the same as it did when it was working earlier today, so I presumed that it was not a Jackd issue, whereas PulseAudio and Audacity were the only audio related updates this morning.

What I do find interesting is that you can actually see the PortAudio and Jack sink/jack source in your Jack Connections. I have never seen that, even when it was all working, I presume audio was just going through the system:capture_n/ system:playback_n. So when audacity 2.4.2 was upgraded to 3.0.2, I saw no difference in my configuration and the “Jack Audio connect kit” simply disappeared from interface host list.

I have found the 2.4.2 deb file on http://ftp.debian.org/debian/pool/main/a/audacity/ but none worked, due to “dependency issues”. Ho hum, the tunnel has collapsed behind me, so I need to dig on…

So I gather I do need to go forwards and try and install from source code. I have never tried that with audacity, are there instructions anywhere?

:smiley: Love the analogy.

So that I can link to the best instructions, do you know which version of Ubuntu your version of Mint is based on?

I have pulseaudio-module-jack installed.
It used to be necessary to manually load the modules

load-module module-jack-sink
load-module module-jack-source

but in Ubuntu 20.04 they are loaded automatically (if installed) when Jack is running.
I think it’s this part of /etc/pulse/default.pa that does that:

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
load-module module-jackdbus-detect channels=2

I’m not actually using PulseAudio Jack Sink or PulseAudio Jack Source, but they help to keep everything sweet. If they are not present, PulseAudio and Jack can start fighting, and PulseAudio usually wins.

When Audacity is playing (as shown in my screenshot), it automatically connects to the playback device selected in the Device Toolbar.
In the “Connections” window you can see this - Audacity’s playback port is “PortAudio” (Output Ports) and it is connected to “System” (Input Ports).

On recording, a “PortAudio” client will appear in the “Input Ports” panel.

Mint 20.1 Cinnamon/Ubuntu LTS (Focal Fossa)

I’m on Xubuntu 20.04. These instructions work for me: https://github.com/audacity/audacity/blob/master/BUILDING.md
The latest release source code (“Source code (tar.gz)”) is available here: https://github.com/audacity/audacity/releases/tag/Audacity-3.0.3

(There is now an official AppImage release, but unfortunately it does not yet support Jack. Hopefully future AppImage releases will.)

Thank you steve. Audacity 3.0.4-alpha-20210802 compiled and installed perfectly by following the instructions that you provided and it now has the Jack Audio connection kit option in the device drop-down and it can record Jackd audio.

What is more, I no longer have to start Audacity with the command “GTK_IM_MODULE= audacity” from a bash file. I can now open a file in Audacity!!!

This is excellent progress. Thank you so much for your efforts. Audacity is one of my most important installs, it is an awesome piece of programming.

I would generally recommend using release versions of the code rather than alpha versions, but if your new build is working without problems then I’d suggest that you stick with it until the next release version becomes available.