I've found some bugs in Audacity with some plugins


Today I have downloaded the latest version of Audacity (2.1.0) to update the previous version I had (2.0.6). I must say that the new features are great, specially as it’s said, the noise reduction effect works better than before.

However, and in spite of all the good news, a problem has happened me: I’m used to work with all sorts of effects on Audacity, but there is a VST effect that don’t work anymore; I try to load it in Audacity and the program crashes. This plugin is named Auto-Tune. This didn’t happend with the old version.

In addition, I have installed the Ladspa plugins pack, but some pitch shift effect neither don’t work, for example the “higher quality pitch scale”, and others.

Then, I wonder what can I do, or this is a bug with some VST plugins.

Thank you!

It’s up to the plug-in developer to decide what hosts to support and it’s up to them to test and debug their plug-ins to make sure they are compatible with the supported the hosts. [u]The Antares website[/u] specifically says their plug-ins are incompatible with Audacity.

Many VSTs work with Audacity but very few commercial VSTs officially support Audacity. I assume that’s because most people using free software don’t want to pay a few hundred dollars for a VST.

With free VSTs it’s usually hit-or-miss since the developer usually can’t afford to purchase all of the popular DAWs and audio editors for testing.

Which exact version of AutoTune? Please give us the address where we can download the exact AutoTune version you are using.

There are VST alternatives that do (largely) work in Audacity, like GSnap (the MIDI features don’t work in Audacity) or Autotalent.

Unfortunately, the four LADSPA-swh plugins that require the presence of libfftw3f-3.dll don’t initialise in Audacity 2.1.0. This will be fixed in the next 2.1.1 release of Audacity. Or you can try the latest 2.1.1-alpha from the top of gaclrecords.org.uk.


Sorry, I prefer to hide it because the VST is cracked due to I don’t have money to buy it. However, I am using Auto-Tune Evo v6, and it worked with old
versions, even the Audacity 1.3. But if it doesn’t mater, I can upload it.

I will try Evo v6 if it has a legal demo.

Obviously a cracked version of a plugin may or may not work, and you are on your own if you use cracked plugins.

The alternatives to AutoTune that I suggested are legal and free.


I have another problem. I would like to change a parameters of some MDA vst effects, but It doesn’t work. Examples of those are:
MDA tracker, MDA voc input.
Also, is there another vst plugin to tracking?

I was not able to test any legal version because iLok is required.

Did Evo crash when “Register Effects” tried to register it, or later when you called Evo from the Effect Menu?

If it crashed when you tried to register it, please try 2.1.1rc3 from Audacity download latest version. Use Effect > Manage… then “Enable” the effect.


Thanks, yes I agree. These plugins don’t work correctly as real-time preview effects. You will have to go back to Audacity 2.0.6 to use those plugins. I will put it on our bug tracker when I have time.

You could search on KVR Audio or similar to find that out.

There is Frequency Tracker in the LADSPA-swh plugins set.


Yes, you have to create an account in another external site, get the USB Keylock and I don’ know what else, even if you want to use the demo version.

It crashed when registering it, even I thought the number of plugins was too long for Audacity. As I said, Auto-tune worked without problems since 1.3.12 Version with VST Enabler, and 2.1.0 was the first version which gave me those problems.

Ok, I will take it into account, but sincerely I preffer to wait until the last version can be released.

Thanks a lot for your answer!

Unless we find a serious bug in the next 24 hours, rc3 will be the release version of 2.1.1.