It worked before, now it doesn't

I have a nice, old Panasonic turntable running through an Ion Vinyl Forever black box into the USB 3.0 port on my HP laptop. This rig worked the other day. Now it doesn’t, and I have no idea why. I’ve looked at just about every plug, switch, and setting of which I can think, and I still get absolutely no indication of sound from the rig. I realize this is a question perhaps better posed to Microsoft types; but I’m looking for anyone else who may have had similar experiences and resolved them.

Thank you for your time and consideration.

Have you selected the USB device as your [u]Recording Device[/u]?

You can also try [u]Listen To This Device[/u]. If it’s working, you should be able to hear it without running Audacity or any other applications. (After you’re done troubleshooting, turn that off or turn off Software Playthrough in Audacity to prevent echoes.)

Or, if Windows thinks it’s a microphone it may have disabled during a privacy update. [u]Info here[/u]

I don’t get the option to select USB Device as my recording device, even after reinstalling both the driver for the computer and the software for the Ion Vinyl Forever device. If I select “Listen to this device” for Stereo Mix, I get an echo from sources such as YouTube — and I still get nothing from the turntable. There’s only one USB device showing in my Audio Inputs in Device Manager; it’s a microphone. It’s enabled. I’ve checked the privacy settings; the microphone is supposedly enabled there as well. The most aggravating thing is, it worked before; now it doesn’t. Wait, I said that already. But I can’t think of anything that has changed to keep this turntable from being heard by the computer.

Look in the Windows Sound Control Panel in the recording tab.
When the Vinyl Forever black box is connected to the computer, you should see a recording device listed that is not there when it is not connected.

If you can’t see the device in the Windows Sounds Control Panel, then check the USB cable, and check that the device is turned on (if applicable). If possible, try the same on another computer.

If you still cannot see the device in the control panel, then the device is probably faulty.

I don’t see USB Device of any kind (except for a mike) when I click on Sounds (did I mention I have a Win10 machine?); never have. Show Disabled Devices is checked, as is Show Disconnected Devices. The little, blue light is glowing on the Ion box; I’ve pulled and reseated all the plugs, including the RCA plugs from the turntable; I’ve even checked the phono cartridge to see if a wire came loose there. In fact, I tried swapping out the USB cable on the black box. No happy. Everything worked one night; the next night, nope. Driving me nuts. Audacity is not responding to MME or any options under that tab; it’s not responding to Microsoft Sound Mapper or any available input. And it worked before, with the Ion box, with the same cables. Makes no sense.

Is that mic still listed in the Windows Sound Control Panel when the “Vinyl Forever black box” is NOT connected to the computer?

Do you have a USB microphone connected to the computer?

  1. Interestingly enough, no. In fact, I disconnected and reconnected the USB plug and watched the mic disappear and reappear.
  2. No.

Also interestingly, when I plug a headset into the conveniently provided front-mounted headphone jack, I do hear output from the unit. I’m going to have to find that USB mic input in Audacity and see what happens.

I don’t see my previous reply to this post yet; however, I just tried the process in the link suggested.

No happy. “Allow access” is already turned on. So I don’t know what the problem is. The box works; it outputs to the headphone jack. The connection doesn’t matter; I’ve used several USB cables between the computer and the box. I’ve even plugged the box directly into the computer with no change (it was going through a hub before). I have no idea now why this rig worked before and doesn’t work now…unless it’s because I upgraded Audacity from 2.2.2 to 2.3.0. Unlikely I can get 2.2.2 back to try that prospect.

OK, I still had a 2.2.2 installation file on my computer. Uninstalled 2.3, reinstalled 2.2.2. No change, so I reinstalled 2.3. This is incredibly frustrating. I’m one track short of ripping a double album that I’ve been trying to convert to electrons for at least ten years.

OK, so that shows that Windows sees the “Vinyl Forever black box” as a USB microphone.

Ensure that the “Vinyl Forever black box” is connected, and open the Control Panel again and go to the “Recording” tab.
Start playing a record.
You should see a green meter next to the “USB mic” moving up and down in time with the music. Do you see that?
Adjust the recording level as necessary to get a reasonable level, but not maxed out - you need to allow a little “headroom” to avoid distortion (clipping).

Let us know when you’ve got that working. The rest should be straightforward.

No happy on the input signal. No evidence of signal at the USB mic.

Are you able to test the “Vinyl Forever black box” on another computer?

Been gone for a while, obviously. Yes, I was able to test the Vinyl Forever on my old computer. Strangely, it no longer worked there, either. Logic says there’s something wrong with the unit. But after putting the new(er) computer back together and pounding randomly through various and sundry setting dialogs (HULK SMASH!!), I tripped across something whose location I no longer remember, that showed the USB microphone/turntable was disabled — after everything I had done to enable it. When I enabled the turntable on that mystery window, voilá!, as the French say. So now it’s working again. Just wish I could remember how I found that one window where the turntable was disabled in case it happens again. But in addition to finishing the project that started this odyssey (or idiocy, if you prefer), I’ve successfully ripped another LP to computer. Thank you for hanging in there with me.

Windows has a habit of doing that when it makes updates to the W10 operating system :angry:

WC

And for future reference

  1. right-click on the speaker icon at the bottom right of your screen
  2. select Sounds
  3. click on the Recording tab
  4. and there you can make changes if needed

WC